Fully Kiosk - Can't Reach Remote Access Settings from Different LAN PC

I’m a paid Fully Kiosk user and I have remote access turned on for a Lenovo tablet. While I can access the remote settings page on the tablet running Fully Kiosk itself at http://[ipaddress]:2323 in a browser, I cannot access the IP address from another computer on my LAN. I get “Connection Timed Out”. Any suggestions?

Verify that your other computer didn’t automatically change http:// to https://, a lot do and that may be why. Otherwise, perhaps FK (which I also use and do not have this problem) limits the number of connections and you are exceeding it but I don’t think that’s the case.

Did you turn on “Enable remote administration”, “Remote administration from local network” and enter remote admin password in fully’s settings? (tab “remote administration (PLUS)” )

Also: are tablet and your PC in the same local LAN subnet?

Neither with the “s” or without work on the LAN PC. Thank you though.

Yes. All Enable Remote Administration settings are on except for the cloud setting. Both LAN computers are on 192.168.0.x. And like I mentioned, I can access the tablet with Fully Kiosk running in a separate browser on that tablet fine. It’s as if the tablet is perhaps not allowing me to access it on the LAN. Perhaps it’s a tablet issue preventing a remote connection though I can access it via Home Assistant.

In that case, either tablet or PC prevents local connections… just to make sure double-check gateway and mask on both devices.

Can you ping tablet’s IP from PC?

Host is unreachable. It’s a Lenovo Tablet. Anything I can do on this? How can Fully Kiosk and Browser Mod reach it through HA, but I can’t locally?

Install any ping app on your tablet and see if you can ping your PC - i think you won’t… that means something is wrong with your settings either on PC or on tablet.

If you intend to use tablet as HA then first smart thing to do is to assign static IP to a tablet: enter IP, GW and mask into wifi settings. Again: make sure that only IP’s are different on tablet and PC, GW (that’s rouer’s IP) and mask MUST be the same on both devices!

Also make sure NOT to assign an already occupied IP (ping IP you intend to use to double-check - it must be inaccessible).

Ping must be alive, that’s essential.

There are only a couple causes for this:

  • The network and/or subnet mask does not match the tablet or the tablet doesn’t match your other network devices
  • You have a VLAN or other segmentation of your network that is causing the problem

As @Protoncek pointed out, if you can’t ping it then you are never going to make it work, unless the tablet has some form of firewall that is blocking access.

I want to thank everyone on this board for responding and helping me resolve this issue. I isolated the issue to this one particular tablet since my other Lenovo M8s were working fine. Turns out, the MAC address was set on “random”, and thus the LAN computers were not connecting to the correct IP for the tablet. All is well now. Thank you again!

2 Likes