Funny file in HA home directory (eg. HKZ0MH~P)

Hi, I realized that there are some wierd files in hassio home directory (eg. HKZ0MH~P, HDTFT8~5) with no file extension and unable to open with text editor. I have several of such files of 0 size, and 1 of about 200K size. Anyone can advise what are these files for, and is it generated by HA or 3rd party?

what is the output of

file filename_with_content

It is binary file, i tried open with text editor but it just show gabbage

You haven’t answered my question.

how do you get the output? can I attach the file here?

I have deleted some of the Hxx files but it still self-generated. Currently, I have this H1SOTA~G which is of 0KB.

discovered another strange observation. The H1SOTA-G file is found in the config directory when I connected via SMB. However when I login using the HA terminal, I am not able to locate the file H1SOTA-G in the config directory. strange.

I get similar when I have some sort of database issue and it is rebuilt. One of the files is the same size (1.7GB) as the old database. I tried just moving them and see if it would affect anything and it didn’t so now I just delete them

I had similar files, They were preventing me from doing a snapshot and restore on a HA machine. There is a 1GB limit when restoring snapshots when onboarding.

After removing those files I’m guessing they had to do with MariaDB, I had to remove and reinstall that addon, everything else worked as expected.

I use the built in DB

Then I have no idea what they are.

In the ssh terminal type


Where FILENAME is the file you want to identify.