FYTA - new flora sensor

Hi, has anyone tried these sensors?

It seems to me like a good alternative to miflora built on BL5, you can even buy a wifi module to extend the range. But the question is whether BL is enough to integrate.


I also looked into this. I’m not yet sure if direct link with BT is possible or if you need hub to be able to connect to cloud via API. I would like if all data could be kept local.

1 Like

Has anyone gained any experience with these devices in the meantime?

1 Like

Not yet. I plan to get them even with the risk of not pairing them yet. But I have a lot of other priorities, so I’ve put it off for now.


Hey Mag!
Did you try to integrate fyta yet?

These look pretty cool… and reasonably priced. Anyone manage to integrate them with HA yet?

I noticed there is an OpenHAB integration for FYTA… and they seem to have a failry straightforward public API.

There is also an IFTTT integration.


I started with an integration for HA. It is my first integration, so please be gracious.
The current state can be accessed here:

The integration is still in development, but most of the sensors already work, so that you get a good impression.


Amazing! Nice work, @dontinelli!
My Fytas are on their way, and I look forward to trying this out.
:potted_plant: :two_hearts:

Hey, @dontinelli .
I installed the integration and went to add it but I get the following error message…
Config flow could not be loaded: {“message”:“Invalid handler specified”}

I put the files in config\custom_components\fyta is that correct?

Also, if you need an icon, let me know the specs and I can make one for you. :slight_smile:



Had the same problem, just had to add a dot in front of the imports:


.fyta_connector import
.fyta_exceptions import


.fyta_exceptions import


.fyta_connector import


.fyta_exceptions import


.fyta_client import
1 Like

That fixed it!
This add-on works super well… very easy to use. Amazing!

With a Mushroom template card, I was able to create a nice GUI for my plants’ watering needs…

Secondary Information

{% if states('sensor.gilou_moisture_state') | int == 1 %}
  Needs watering
{% elif states('sensor.gilou_moisture_state') | int == 2 %}
  A little thirsty
{% elif states('sensor.gilou_moisture_state') | int == 3 %}
  Doing great!
{% elif states('sensor.gilou_moisture_state') | int == 4 %}
{% elif states('sensor.gilou_moisture_state') | int == 5 %}
{% endif %}

Icon Color

{% if states('sensor.gilou_moisture_state') | int == 1 %}
{% elif states('sensor.gilou_moisture_state') | int == 2 %}
{% elif states('sensor.gilou_moisture_state') | int == 3 %}
{% elif states('sensor.gilou_moisture_state') | int == 4 %}
{% elif states('sensor.gilou_moisture_state') | int == 5 %}
{% endif %}

Then I added it to my dash, along with the battery sensorts…

Nice! :smiley:

(Yes, my plants are named after the dodgy cops from the French TV show, Spiral).


Sorry for not having answered earlier. I somehow missed your post as there was a similar one in the github repository.
Happy that you like the integration. Your cards look great. The development is still ongoing, so watch out for improvements…

1 Like

do i need a Wifi Hub from FYTA to connect them?

AFAIK you just need Bluetooth access, so no

Hmmm. Went to reinstall this integration so I could keep it up to date with HACS… but now I get this error when setting up. Any tips?

File "/config/custom_components/fyta/config_flow.py", line 44, in async_step_user
    fyta = FytaConnector(user_input[CONF_USERNAME], user_input[CONF_PASSWORD])
File "/usr/local/lib/python3.12/site-packages/fyta_cli/fyta_connector.py", line 42, in __init__
    self.timezone: ZoneInfo = datetime.UTC if tz == "" else ZoneInfo(tz)
AttributeError: type object 'datetime.datetime' has no attribute 'UTC'

Can you try to uninstall the integration and make a new installation over the config-flow?

I tried to delete and re-install a few times, but no joy. What do you mean when you say “over the config flow”?

I reinstalled from an old back-up and everything went swimmingly. Not sure what it is about the latest version that is different.


With deletion and re-installation I meant that you only delete the integration from https://xxx/config/integrations/integration/fyta. When you then re-install, you should be asked for credentials again.

There seems to be an error in the import of the UTC const in fyta_cli. Will have to further investigate into this.

I assume I found the error in fyta_connector.py. I updated the file on GitHub - dontinelli/fyta_cli. @dt1000, do you have the possibility to update your local file /usr/local/lib/python3.12/site-packages/fyta_cli/fyta_connector.py? If yes, could you let me know if the fix works for you?