Garaget Stopped working

After upgrading to HASS.IO 0.108.1 this morning my Garaget component started failing. I have tried to downgrade back to 0.107.7 where it was working but I am still getting the errors below. I am able to control the device through the app or the website online.

Logger: homeassistant.components.garadget.cover
Source: components/garadget/
Integration: garadget (documentation, issues)
First occurred: 9:30:43 AM (2 occurrences)
Last logged: 9:30:43 AM

  • Unable to retrieve access token
  • Garadget device ################ seems to be offline\

Can anyone help?

Looks like others are trying to solve the same issue on the Garadget forum:

That did point me to a solution. Thank you!

1 Like

Please share… I cannot get mine to work… been trying most of the day.
I tried everything suggested…user/pass does not work… auth_token: and access_token: does not work…

All I see is Cover Entity not available I used the web interface and use the document inspector to get the device and token

Help please!! No erors in my config.yaml


  • platform: garadget
    Garage door:
    device: 43003a000451353432383932
    access_token: e8d10a089a8fde993f571802eb08ca255e59d3eb
    name: Garage door

Did you ever get it working?

Adding myself to this thread. Garadget has not worked with Home Assistant for several weeks now. Watching for a solution.

I solved it (for me at least). It seems that using ID/Password no longer works. You must now use Access Token instead.

See this to change your config to use access token instead of id/pwd:

See this to find the access token for your garadget:

Following the information in those two threads got me back up and working.