Gd-dc5 tasmota HA


I bought such a Tuya gd-dc5 device, uploaded Tasmota to it and the question here is whether someone managed to configure it and connect it to HA?


I haven;t searched extensively, but I can’t see any tasmota config for the exact model, but there is one from the same manufacturer, looks like perhaps an earlier model?


Did you ever work out the configuration for this device? I’ve got one to play with now.

1 Like

Bump again!

Has anyone successfully configured this type of garage door opener with tasmota/HA?

Cheers, Nick.

Do you have one? If so could you take non fuzzy clear photos of both sides of the circuit board, showing the printing on the chips. The FCC photos are hopeless.

Hi Nick,

Thanks for the reply. I’ve taken some photo’s as follows:

I used Tuya-Convert to successfully get Tasmota on the device last night… I set the module to Generic (18) and tried a few settings following one of the Tasmota guides, however the only thing I’ve been able to find is that if I set GPIO14 to Relay1 I can get the relay to click when turning the toggle in the Tasmota UI OFF. It does nothing when switching ON, so I might just need to invert that one. I can’t find the LED, the button on the front of the unit or the reed switch. I’m actually not sure if the button actually operated the relay with the default firmware as I never tried it. The manual only references long pressing the button to put the unit in pairing mode.

It is powered by 5v microUSB. Actually looks like a pretty neat little device but I can’t seem to find anyone who has put Tasmota on it and had it working. I also have another garage door opener that uses 240v and that one has a template available and uses TuyaMCU, but when I try that template it reboots the unit over and over until I reset it back to factory Tasmota.

Thanks for any assistance you can provide.

Cheers, Nick

EDIT: Just to clarify, the relay is a momentary one, so when I get it to click it actually clicks twice… it clicks then clicks again about a second or so later, but Tasmota does not follow it. My other opener is always OFF, so when I click it ‘ON’ the relay clicks on and off then off again like this one, but Tasmota then goes back to OFF automatically. With this one I have to click it back to ON, then click OFF again to get it to physically click the relay. Hopefully that makes a bit more sense.

Do you have the original firmware? Tuya convert backs it up by default. If so try running

strings firmware.bin

There should be some json in there. See this post Anybody got a config for "LVWIT" RGBW bulb?

More: this is the manual for the main chip

You may have to do some tracing around the circuit board. Take the power connector off first.

Can you tell me what is written on the chip next to R6, the one with 8 pins, I can’t quite read it. Ta.

I am following this thread as I have the exact same opener on the way. Very new to the esphome community but I have been able to flash 2 tuya plugs and a switch. Once I get my opener I will be more than happy to do some testing to get this working offline.

Was able to find this page with the diagram of the chip hopefully it will be of some help.

There is better diagram of the chip in the FCC site manual

Anyway, these are well known chips, it is the connection to the outside world we need.

I am sure we can get this sorted though.

Turns out I received a slightly different model.

Looking forward to your results. Make sure to look at the old firmware as I suggested above.

I was able to set it up in ESPHome using GPIO12 as an inverted relay with a turn_on_action that turns it back off 500ms after its turned on, If I didn’t have this relay clicks forever. Still can’t get sensor to work as whenever the senor is tripped in clicks the relay which then stops/start garage door. No luck with the backup firmware.

Here is what my ESPHome yaml looks like right now, Hoping to get sensor working later:

  name: garage_door
  platform: ESP8266
  board: esp01_1m

  ssid: !SSID
  password: !WifiPassword



  password: !APIPassword

  - platform: gpio
    pin: GPIO12
    id: relay
    inverted: true
  - platform: template
    name: "Garage Door"
      - switch.turn_on: relay
      - delay: 500ms
      - switch.turn_off: relay

How did you flash it?

I just used Tuya-Convert

And tuya-convert saves the old firmware,

What is the output of

strings oldfirmware.bin

where oldfirmware.bin is the file in question.

This is what I get, I can’t make sense of it but like I said I am pretty new.

I suspect this piece would help setting it up


Interesting so if I am reading this right:

GPIO13: Button
GPIO12: Relay
GPIO04: WFST (Whatever that means)

What F—ing Switch is This