GE Enbrighten Smart Fan Control failure

Hey all. Having an issue with a Z Wave GE Enbrighten Smart Fan Control, hoping someone can point me in the right direction…

I have two of these switches installed in two different rooms with identical ceiling fans connected to each. One works flawlessly, the other will completely die every 2 or 3 days. Z Wave node becomes “dead” and offers no control, AND physically pushing the switch in the wall doesn’t do anything to control the fan; it’s just stuck in its last state. And the indicator light is dead. The only way to get it back is to flip the breaker off and back on. The problematic switch has 3 other perfectly reliable Enbrighten Z Wave products (dimmers) within 5 feet, so I’m assuming it’s not a zwave network failure.

Naturally I assumed the switch itself was jacked. Here’s the kicker: bought another one, replaced it, and the new one is doing the exact same thing. Not quite sure what else I can do… any tips? TIA!

1 Like

Need to know a few things.

  1. What Zwave implementation? Zwave JS, ZwaveJS2MQTT?
  2. What coordinator stick (model number matters) and what firmware revision is on the stick?
  3. How is that stick connected to HA?
  4. How many OTHER Zwave devices do you have, particularly, line powered repeating devices?
    How are your Switches and other devices Joined? (S2 Security? S0 Security? No Security?)
  5. Have you run a repair on the device, the network?

Thanks for your reply! Here’s some answers:

  1. ZWave Implementation is ZWave JS
  2. Coordinator is the standard HUSBZB-1, I’m not sure how to check firmware on it.
  3. Stick is connected to Home Assistant (hosted on RasPi4) via 10’ Powered USB Extension run up into the attic to provide maximum coverage over the house.
  4. There’s 15 other ZWave devices on the network, all of them GE Enbrighten dimmers (and the one additional fan controller I mentioned) and all hardwired and repeating devices. All other devices have been rock solid since installation (roughly 9 months), not a single failure, and 11 of these other devices are within ~15’ of the problematic one. All are joined with S2 security.
  5. The switch is unable to perform a “heal” repair. A “heal” on the network does not reconnect to the switch. However, I’d like to reiterate that the switch as a whole is failing; usually these Enbrighten switches will still work as a regular switch on the wall if disconnected from the ZWave network. This switch, though, becomes entirely unresponsive, and is stuck in it’s last state. i.e., my ceiling fan has been stuck on “low” for the last 3 days because I’ve been too lazy to go flip the breaker. No amount of pushing the switch on or off has any effect on the fan, nor it’s connection to the ZWave network.

I’m also experiencing this exact same issue with the same fan control switch. Have you been able to find a solution?

1 Like

I just put one of these in a couple of days ago, and it did this to me today. I was testing % adjustments from HA and tried using the switch to see if the percentages would update on the HA side, then it sort of locked up. I hit the upper paddle a few times consecutively out of frustration, then realized I may have given the switch some kind of command. I used the air gap to remove power to the switch and bring it back, and now it’s working. I still think it may have been something I did.

I’m having this exact same issue. This has now happened twice to me. I replaced the switch with the same model thinking it was a faulty unit, but 1 month later and it happened again.

Anyone figure out why this happens?

@nanooman I’m not familiar with what the air gap process is to bring this back. Mind sharing?

I have had this exact same issue. I have two switches that have worked flawlessly for months. I had one that would go “dead” after random amounts of time. Local switch will not work. Flip the breaker, and the switch is back online immediately and works an unknown amount of time.

I called support and they sent me a new one. The replacement is doing the same thing, but it appears to happen significantly less often… I’m going to contact them again and see if there’s anything else I can do to test/troubleshoot.

I emailed Jasco support back (and send them a link to this thread). They called me a few days later and asked me to send one of the failing switches to them. They have received the bad switch and have started investigating.

One thing I have found that helps keep mine running is reduce the number of commands sent to the switch. I use Node Red and so I put a check in front of each Call Service command to see if the switch is already at the desired state and if it is, it will not pass the duplicate command to the switch.

Same for me. Seeing the same exact problem. I see there is a firmware update when looking under the OTA Updates section in the z-wave UI (and checking the pre-release box). Has anyone tried the latest firmware v0.51 to see if the problem persists?

v0.51 Changelog

  1. Added parameter 3 (adjustable LED behavior)
  2. Added parameter 84 (factory reset)
  3. Added experimental parameter 40 (fan speed ramp rate)
  4. Update devkit to 6.84.00

Is this the GE/Jasco 14287?

Jasco / Enbrighten 55258 / ZW4002

I am still waiting from an update from Jasco (this has taken a really long time)… I am getting the firmware update message also, but I’m confused because the current version is listed as “v5.50” and the update shows “v0.51”. Something isn’t lining up…

I just noticed that the switch having an issue connected using S2 Authentication and the two NOT having an issue connected with no security… Anyone else have a correlation?

I am having these same issues. Two switches, same exact fan model. Both will quit after a few days, and then if I flip the breaker they will come back. Really interested in seeing what the solution to this is.

One other thing of note… the fans never get to max speed. My expectation is that the max/3 setting would produce the same fan RPMs as when I hardwire the fan in. But the output is noticeably less. I am getting this behavior on my two failing Jasco 55258’s, as well as the one that works.

Anyone else seen this behavior?


What security are your switches connected with?


Was S2….and that seemed to have been my problem. Once I removed the node and added it back using S0, I have yet to observe any disconnects. Been going for about a month with no drops now, so for me, I’d say switching to S0 fixed my problem.

S0 or no security?

S0 has 3x the security overhead.

Personally I don’t join switches or fan controllers with security at all. I have three of this model at this level and have not ever experienced an issue.

The two switches I have that work flawlessly show “No Security” in Z-Wave JS. The one with issues is S2. I didn’t “knowingly” do anything different when I connected these. I’m not sure why the newest one connected using S2. (I’m relatively new to Z-Wave though…)

1 Like

Sorry, you’re right it was no security. I just assumed S0 = no security, but that doesn’t seem to be the case.