GE/Enbrighten ZWave Fan Switch 55258 - Controls show "This entity is unavailable."

I’ve recently added an Enbrighten/GE ZWave fan switch (model 55258). After adding the switch via the normal ZWave “Add Device,” and watching the interview happen successfully, I see the device in the devices list, but all of its “Controls” display “This entity is unavailable” and I can’t add controls to any dashboards or such. The entities for the device don’t show up in the “entities” list. I do have about 30 other devices on this ZWave stick - all working successfully. This particular switch does show status “Alive” and when I manually press the buttons on the switch, events do show up in the device’s logbook.

Here are the build and version details I think might be relevant. Any troubleshooting advice welcome!

Raspberry Pi 4
Zooz 700 Series Z-Wave Plus S2 USB Stick ZST10 700
Z-Wave JS Addon version 0.1.74
Home Assistant 2022.10.4
Supervisor 2022.10.0
Operating System 9.2
Frontend 20221010.0 - latest

Reinterview device

I have removed and re-added as well as reinterviewed many times - same results each time.

Does the device say “Ready: Yes”?

Post Device diagnostics (Device page → Device Info → … → Download diagnostics) and driver debug logs of interview.

Not sure how you install but maybe check group associations and verify if it is in Lifeline group.
This is possible in zwavejsui but not sure how this is done in HAOS install

In the device config page (https://xxxxxx/config/devices/device/yyyyy), under Z-Wave Info, I see “Status: Alive” and “Ready: Yes”.

The diagnostics are here: Untitled - Pastebin
The log output during a re-interview is here: Untitled - Pastebin

The fan entity is disabled by the integration for some reason, which I don’t see why yet. But have you tried enabling it manually?

1 Like

Ah ha! That fixed it.

I didn’t realize you could enable/disable entities and not just devices.

Should I do the same for the other entities on that device?

The ping and node status sensors might be useful. The number.living_room_ceiling_fan_basic is mostly useless (just duplicates the fan entity functionality), so I’d say no to that one. That one is disabled by default, while the others are enabled by default.

No obvious reason why the entities were disabled from looking at the dump and interview logs. It would require some extra debug logging and a repeat of the process to possibly determine.

The only other thing I could think of, did you disable new entities for the entire integration?


Thanks for the help. i’m not sure I care much about root cause - this is the only device that seems to have this issue (I can’t find that configuration anywhere - but I’ve added about 30 other devices in the last few days and none have been disabled).

If you’d like to continue looking for root cause, i’m happy to help with that - but as far as I’m concerned, problem solved!