GE paddle dimmers (14294) problems

I bought 3 GE in-wall paddle dimmers (14294) and they have really disappointed me. It seems as if they only work correctly 50% of the time. On/Off commands do nothing and states just fail to update. I have to toggle it several times it order for them to work. And 90% of the time the first toggle after a reboot fails.

I have an Aeotec Z-Stick Gen5 with the switches in line of site and less then 20ft away. I’ve tried moving the Pi closer, adding another device in between them, healing the network, multiple reboots… nothing.

EDIT Heres a video of some of the symptoms…

These dimmers, by default, take a few seconds to ramp on and off. Without going into all the details, you need to add refresh_value: true and delay: 3 to your configuration. See:

E.g., this is what I have in my configuration.yaml for my z-wave switches & lights:

  usb_path: /dev/zwave
  network_key: !secret zwave_network_key
  polling_interval: 10000
      refresh_value: true
      delay: 3
      polling_intensity: 1
      polling_intensity: 1

light.family_room_lamp is a GE dimmer (albeit a different model.)

1 Like

Thanks. added the polling_interval, refresh_value, and delay attributes but it makes no difference.

I didn’t watch the video that closely, but it did look like maybe you were clicking on the light fairly quickly. If you turn the light on or off from HA, then you have to wait for that to finish (and the refresh delay to complete) before the HA component will update. So, assuming the ramp on and off time for your dimmer is 3 sec (which I believe is the default - actually 2.97 sec), then when you click you have to wait for 3 sec to see the HA component refresh and show the correct state.

There have been times were I haven’t pressed it for hours and it still doesn’t turn off or on. Or sometimes I press it and the UI freaks out and turns the toggle on and off a few times but no change to the state of the switch