GE Z Wave Dimmers About to Kill Me

This has got me stumped and I’ve tried everything I know to try.

So back in 2018, I installed some GE Z Wave Dimmer Switches. At the time I had Smartthings and set them up in there. Decided I didn’t like that and abandoned it and used them as dumb switches. Until now…

Fast forward to today. I’ve finally got Proxmox running HA on a VM (all of which I couldn’t have told you what those were a week ago) and I’ve started adding devices. I added the Z Wave JS integration and it refuses to find them. Any of them! I restarted, searched, moved the laptop running HA around, etc. The USB running Z Wave seems to be functioning properly. In an attempt to trouble shoot, I pulled the old Smartthings hub out and, after some tinkering, it found 2 of the 7 switches I have. It won’t find the other five. But that’s two more than HA found.

I’ve restarted each individual switch (3 taps up, 3 taps down quickly), I’ve used Z Wave Exclusion to make sure the switches aren’t attached to Smartthings, spent time on the phone with both Jasco ZWave and Samsung support, I’ve tried everything I know to do to pair. I’m pulling my hair out here…starting in HA has been a rough road! (I’ve already got another thread asking why some Zigbee light strips won’t work despite being configured correctly).

I’m starting to think some of the switches are bad but they manually turn the light on and off fine. And the two that Smartthings discovered refuse to be discovered by HA. Help! Why can’t I find these devices?

Thanks for whatever assistance you can give.

Do these have airgaps so you can remove power then do the 3 up 3 down to reset. If not you may have to shut breaker off / on and within 1 minute 3 on 3 off.

Do you have your z-wave dongle plugged directly into the computers usb port. If so, get an extension cable and get it a couple feet away from the computer - interference.

Can you bring computer close to switches when you include? You can move around when included and heal the network to get missing return routes.

Hope this helps and gives a few more things to try.

1 Like

What EXACT model switches are those GE/Jascos?
The old non-plus ones -12xxx series - don’t have a reset procedure AT ALL and only respond to exclusion. That exclusion can’t be a weak signal NOR through a repeater. 2018 era devices - they could easily have been end of run 12xxx or new stock 14xxx switches. My ST Gen 2 hub used to have a hard time excluding some of my 12xxx Jascos on the far end of the house. I have an Aeotec Gen 5+ stick with a button that can do a general exclude I use when I need to do something like this. You can exclude them from anything that supports general exclude - so bring that laptop next to the switch and put your z-stick (now on an extension cable - see below) right on top of the paddle and exclude that sucker again. :slight_smile:

(You laugh, but before the Aeotec stick, I used to do this with my G2ST hub and a 25’ Cat 5 cable, I still have do this with my current pi and Aeotec Gen7 stick to include my Schlage locks…)

What version of ZWave JS are you on? Have you captured any debug mode logs from your zwave integration in HA while running the join procedure?

What Zwave stick are you using? (Model number?)

And I second the advice to make sure your stick is on a USB extension. If you were non a Pi instead of your VM host, I’d also suggest a USB hub. RF interference seems WAY more of an issue on this kind of setup with USB coordinator sticks than it ever was for me when I used ST. (Your mileage may vary because RF is VERY location dependent)


HOLY **** this helped tremendously! I threw all of that at it but I think it was the air gap switch and reset combo that did it. All of them connected except one, which I still can’t figure out since I’m doing the exact same process. Thanks so much, you saved my whole day!


So I mentioned it above, but I’m down to one that won’t connect even though I’m doing the exact same thing I did with the other ones. Sounds like you’ve had quite a rodeo with these things too!

I don’t have a USB extension cable but it seemed to get the rest. I’m know wondering if somehow it is still included with something else because the one switch that won’t work is one that Smartthings picked up earlier. Can you tell me how to exclude them through HA? I did it earlier through the Smartthings hub but I’d like to learn to do it through HA.

1 Like

Its under manage nodes in Zwavejs2mqtt.

I have the Zwavejs integration but I can’t find anything about nodes on it. I also have a Mosquito MQTT integration but I honestly don’t know what it does. Can you give me a little more description please?

One other thing you can try, when I switched from SmartThings to HA I had two older Jasco/GE switches that refused to reset with the 3 up 3 down game. I ended up plugging the SmartThings hub back in , even though the switches weren’t in SmartThings anymore, I was able to go into Z Utils in the SmartThings app, and sure enough, as soon as I did that, lifted the switch paddle up once, and it was able to exclude them. Doesn’t seem like it should have worked, but my switches work in HA with my Zwave/ZHA dongle now.

1 Like

Actions > Manage Nodes

Then exclusion:

1 Like

I’m currently using the Z-Wave to JS integration but it doesn’t say MQTT. I assume I have the wrong integration?

1 Like

Sorry, my apologies, - for some reason I heard the 2mqtt part - (although, when you have free time, do yourself a favor and research the ZWaveJS2MQTT add on - it has easy buttons for all the tools to manage a zwave network) Anyway, that’s an add-in - JS is the underlying integration… For ZwaveJS go to the configuration menu, then Integrations. Scroll to ZWaveJS, then click the configure button on the bottom left of the card. You’re looking for ‘remove device’ in the middle of the resulting page. Clicking that will bring up a ‘start exclusion’ dialogue.

1 Like

First, thanks for the thorough clarification. Starting out with this stuff has been…challenging.

The exclusion worked. The switch was still paired with the old hub. Once I got it unpaired with the exclusion I got it added to HA. Thanks so much!


This is exactly what it was, still paired to old hub. Once I got it free it worked. Thanks so much!

1 Like