Generac/Honeywell Standby Generators With Mobile Link

I ported an openhab integration for generac/honeywell generators to home assistant.

It uses the Mobile Link api to pull data so this will only work with internet access.

There may be bugs and issues but it is working for me so far.

Install it by adding as a custom repository in HACS and download the Generac Generators integration


Hello. I’m a little new to Home Assistant but making my way around.

I added this as a custom repository and have it running however I can’t get this add in to log me in using my MobileLink login info, which I verified was correct. I didn’t see any menti on of how workaround this, and the only API for generac I see is for their power monitoring (PwrViewer).

Any ideas??


Did install the generac integration in hacs after adding the custom repository? After that you have to select Generac Generators from the add integration menu. That should ask for your user and password

If your username and password still don’t work please check your system logs and let me know if there are any relevant error messages

Recorded a screen recording of installing the integration

My username was my email

Thanks so much for replying and sorry for not getting back right away.

I’m going to try this now and will send a log.

Yes, I used my email for my login and I confirmed it was correct by logging in and out of my app, and also logging in on the web.

I’m having the same login issue. Verified username/password is correct.
Note that when logging into the MobileLink app on the iPhone, a message comes up that says:

“Generac.Application.MobilLink.Mobile” wants to use “” to Sign In.

The next screen that appears (after selecting continue) appears to be using microsoft OAuth2 for credential management. The root domain is

Not sure if that is significant or not. Nothing appears in my logs.

It is working for me, can you try logging in with your username and password at and see if it works

Could you also try enable debug logging then try sign in again with the integration Troubleshooting your configuration - Home Assistant

Thanks for the help Ben!
First, yes, I can login via the link you sent above with no problem.
Second, regarding the debugging, I can’t enable debugging because the integration will not load without the initial successful login. If there is another way to get the integration loaded, I’m happy to enable debugging.

Could you send a screen recording/screenshots of what it looks like when signing in, I just want to see if anything is different from me

For the debug logging you could try add

  default: info
    custom_components.generac: debug

to your configuration.yaml

Debug was helpful.
2023-07-21 10:17:08.944 INFO (MainThread) [custom_components.generac] Could not load login page

However, the next 2 lines are full of data from my account. So, it is clearly logging in and retrieving data.

The login page that I see is pretty standard. I don’t have screenshots or recordings right now, but can work on that if you really need it.

The integration simply says “Username/Password is wrong.”

Hmm I will try and fix

Can you try replace the contents of custom_components/generac/ with With error debug · GitHub

I just added a debug logging statement for the exception when checking credentials. That should help me narrow down what is happening

I just release a v0.0.4 with better logging.
Instead of updating the file yourself you can just download the new version of the integration in HACS.

I would be interested in seeing the debug logs after that

Now I get an “Internal Error” when entering my credentials. Log shows unable to load login page but is able to retrieve my data just as before. A new error line now appears after the data is retrieved:

ERROR: wrong value type for field “deviceSsid” - should be “str” instead of value “None” of type “NoneType”

Hope that helps.

Ah great ok I will have a fix for this in a few miniutes

1 Like

Try v0.0.5

That did it! Thank you so much for your support and for porting this to HA. Been waiting for it for a long time!

1 Like