Generic Camera Help

Hi,

I am trying to setup Generic Camera feature to display my CCTV camera. The URL uses rtsp://192.168.0.4:554/ch01/001/0 which can be accessed by VLC fine. When inputting the host and credentials into generic camera on home assistant it displays a time out error. I have tried every setting and my credentials are correct.

Try other integration as e.g. onvif or check if there is one for this camera on hacs.
In order to see why gen.camera integration does not work, you would need to provide the log probably you need to raise this to debug level for this integration only …this may help

I have tried other addons and still no success. How do i view the debug log?

Add a logger statement (see below) for generic camera only (else the amount of log-rows is exploding) … and restart
Then, in the logs you should see more.
Still … do also try the onvif integration assuming the cam allows this … add some details of the cam too as others may have experience on that brand/type?

Logger - Home Assistant (home-assistant.io)

So i managed to get further now. When loading the cameras on home assistant from the phone app it works fine. On my dashboard it displays a preview of the camera of what it is seeing but when i click on the camera it looks like its trying to buffer and says error loading stream. I have tried multiple devices and browsers and no luck.

See also this post

Could you provide the ‘download diagnostics?’