Geo-location on Android device is not updating... but it is? ... but it isn't? ... but it is?

Hi! Sorry for the confusing title. I must say I’m pretty confused myself!

So this starts with a typical problem - the geo-location entity of one of my android devices has not updated in over a week. Okay, sure.
However, this device’s geo-location is connected to a person entity.
This person entity that uses the android device’s geolocation is updating perfectly fine. I can see the icon on the map move accurately.
Why could this be? The geolocation entity has not updated in over a week and shows the device static on the map, but the person entity that uses this exact data is still working fine. I have tried reinstalling the android app, re-enabling the entities and updating HA to the latest version but to no avail.

device.tracker.YOURPHONE and sensor.YOURPHONE_geocoded_location are different entities. Have that in mind.

device.tracker.YOURPHONE is linked to your person, the other is not but can be used in cards or automations. It will show the exakt street, nummer, city and postcode.

Ah! I never actually realised they were both different. Yes I can see that in my entity list now. is working perfectly, but sensor.phone_geocoded_location hasn’t worked in weeks. I wonder why that would be? Surely the app is doing the same thing?
The device_tracker connected to the person is still accurately updating the map, the ‘device’ icon on the map has been waiting at a cross roads for weeks.

check the companion app logs to see if there is a failure for the geocoded sensor, also double check the sensor is still enabled.

geocoded sensor does not update in the same fashion the device tracker does. The device tracker waits for google to send updates, the sensor checks for updates so they use different APIs.

Thanks for the great advice! I’ll check it out

Checked it out and it all looks good on the android side. All sensors are enabled. Interestingly both the sensor and tracking have stopped working since this afternoon! I’ve checked and there’s no power saving or put-apps-to-sleep active. What could you think a likely cause would be? Out of ideas over here

If you followed the steps then you should keep reading and get the logs that are mentioned.