GeoFency webhook not working

I recently updated to the latest version of HA and the blog says that GeoFency now uses a webhook. So I created a webhook in the integrations as stared in the docs and when I test Entry and Exit the app says the posts were successful but the device tracker in HA is not updated.

I think a few vital steps are missing from the docs.

Check the entity you are looking at maybe? I have seen two entities appear which only differ in the presence of underscores/no-underscores. The one with underscores works for me:

geofency-dev-tracker

Also have a look in your home assistant log for an entry like this when you test entry/exit:

2019-01-31 19:23:33 INFO (MainThread) [homeassistant.components.http.view] Serving /api/webhook/71d19e89c26a1a3e5c50039eb3cf6b9e36212ff0e25213a2534xxxxx to 192.168.1.254 (auth: False)

Paul

The device ids changed to underscores in a previous release and I fixed those. So yes, I only have device trackers with underscores.

In my log I see this…

Received message for unregistered webhook 31212bfd284124b6ac865478bc68aaf1c6d74bd6f1f43b85003db5820

That message seems to indicate that the webhook hasn’t been setup properly?

It returns immediately without attempting to do anything (but without an error response to avoid letting someone know if the hook exists or not): https://github.com/home-assistant/home-assistant/blob/bb21cb6c89740c236a6fedcadb5ab219ae75be15/homeassistant/components/webhook.py#L82

Try setting up the webhook again maybe?

Paul

I deleted it and I set it up again. Same warning, just a different webhook id.

When I added the webhook the only file that changes was /config/.storage/core.config_entries and this was added…

                "connection_class": "unknown",
                "data": {
                    "webhook_id": "da2931d4b03ffe18414fb100af1"
                },
                "domain": "geofency",
                "entry_id": "006cb80f037e43f39a0fc460972a1cd5",
                "source": "user",
                "title": "Geofency Webhook",
                "version": 1
            }

The only reference to webhook in the docs leads me to a webhook automation trigger which is not correct.

I see in the webhook source it is looking for a domain and in the geofency source it has a domain but somehow the webhook is not getting loaded.

I do have the same issue with geofency, I cannot see my devices.
Are there any updates here or hints how to fix this ?

  1. Update to the latest version of HA
  2. Find Geofency under Configuration -> Integrations

If you already added it, remove the integration and readd it.

Hi there,

I readd it several times now, with no success, same behavior.
Any other idea why integration geofency is not working?

Can you provide the steps you’ve tried?

Sure!

  • i removed the Geofency webhook from integration menue
  • added a new one from the same menu
  • updated the URL in the Geofency webhook

One more thing, I’m using nginx as reverse proxy to publish ha outside
With letsencrypt cert

Do you have anything Geofency related in /config/.storage/core.config_entries?

Geofency got fixed by the latest update 0.9.4