Geolocation acting oddly


Geolocation seems to be awry. Note the image. There is no way the two locations can be correct. I am currently in Windermere, but somehow it thinks my phone was in Northampton (near where I live). Any idea what’s going on??

My wife and my phone constantly thinks we are around the corner from our house and outside of the home zone.
We use iPhone XS’s.
I had to enable a device tracker from my Fios WiFi and create a Bayesian sensor to use multiple trackers to improve geolocation.
About 6 months ago it was so perfect in could unlock the door right when we came home but I can’t trust it anymore.

So now I have visited work - at 10am - back home by 11am.

So why oh why is it now doing this with zones?


Both my wife and I have the Android Home Assistant on our Xiaomi Mi 9T.
Geolocalisation used to work perfectly fine, but first my wife’s geolocalisation has frozen at home, so no matter where she goes, she’s located home. Now it’s mine which has frozen few days ago when I was on a roadtrip, so I’m located on the highway indefinitely…
I’ve already tried to restart both phones, my HA server, I have checked the apps permissions, they didn’t changed, both of us have localisation always on.
Any idea of what’s happening here ?

Same issue here.

My wifes location is frozen at ‘Home’ while she is at work. She is using a Samsung S8.
The odd thing is, my son also has a Samsung S8 and on that device the app is working fine!

What do we need to do to get this solved by the developpers?

Try the latest beta build or wait for the next release, the issue was fixed in a recent beta build.

Cheers - just installed the latest beta and will report back :slight_smile:

@dshokouhi, thanks for your reply. My wife is beta tester and the issue isn’t solved with the newest release.

Application version: 1.11.2-7-g46661d4-228-full

Well … it didn’t work for me either. Apparently I am 20 miles away in my office … :frowning:

Also - until I actually visited my Work zone - it didn’t do this (it did randomly teleport me home from the Lakes though). Is the app trying to be clever and using caching for something?

Please make sure to open a github issue…issues are easily lost in the forums.


I’ve raised an issue.

Can you provide the URL? Enables me to follow it up.

Thanks @Neil_Brownlee