Get Generic Camera running

Dear all,

I use the Neolink add-on to create a RTSP server for a battery Reolink cam. Now the server seems to work well: I receive a stream on VLC using the URL


As the Neolink add-on is running on the HAOS machine, I tried this URL and also localhost


to access the RTSP server via the Generic Camera integration:

For some reason, I don’t receive the stream here, while some connection seems to be established:


Am I doing something wrong?

Just “mark/click” the checkbox(dieses bild sieht gut aus.), and click “absenden” “ok” , then close “configuration” and click the CAM, wait for it to load

EDIT: Some Cams also only supports 1 stream, so make sure to close/remove the stream everywhere else, i.e in VLS

btw… if you see delays then also have a look at the webrtc integration, esp. interesting if you have multiple end-use for the camera stream ( I have e.g. 3: NAS+HA+tabler) and they seemed to collide

This worked, thank you!

1 Like

Yeah, i’ve been staring at that a few times, until i figured it out… And then again few years after, until my “old memory” caught up :laughing:

Not sure why it’s like that, could be because one don’t provide a Picture-url