"get history" not working anymore when injecting entity_id via payload


I have a flow that checks the history for a few entities.
Therefore the entity name isn’t hardcoded in the get history node, but send into the node as msg.payload.entity_id instead.

This worked fine in the past, but stopped working now.

I updated Home-Assistant, Node-Red Addon and node-red-contrib-home-assistant-websocket to the latest versions.

I tested it with a minimal demo-setup and set up the Inject like that:

This is how the get history node is configured, and the error that appears after an inject:

And that’s showing that it works perfectly if I enter the same entity_id directly in the get history node:

Any idea what could be the problem here?
Couldn’t find any results with this error message.


  • Core 2024.4.3
  • Supervisor 2024.04.0
  • Operating System 12.2
  • Frontend 20240404.2
  • Node-Red Addon 17.0.11 (Node-Red 3.1.8)
  • node-red-contrib-home-assistant-websocket 0.64.0

Well …

As always, the solution appears in your mind as soon as you press the send button in a community :face_with_spiral_eyes:

Maybe it should have been always that way and it was just a bug that it worked in the past?

The input field you require in msg.payload is now entityId

There is an ongoing shift between entity_id and entityId for reasons that escape me. Check the node help info or the main documentation for the specific node if in doubt.



Thanks a lot for pointing me to that change.

I even looked at the docs (locally in Node-Red, not on the github page), but it still showed me entity_id unter inputs, which was part of my confusion.
But that was immediately after updating the package from the node palette.

I restarted Node-Red later and now I see entityId instead of entity_id.
Maybe that’s cached somehow …