Get Rid Of Discovered Device

I had an esp8266 running a DIY air conditioner. I wanted to change out a voltage regulator and took the opportunity to change the esp8266 to an esp32. Usually I plug the new device into the computer running HA. This time I tried the ESPhome web and connected it to my laptop. Now, I have this phantom device in my ESPhome that I can’t do anything with.


If I adopt it, it will create a new device without an encryption key that can’t be used in HA. If I create a new device and try to over ride what is on it, it will not be discovered by the network because it is already known as this phantom device.

I deleted all references to it using the terminal, but it still shows up.

How do I get rid of it?

2 Likes

Just checking you have removed / deleted the device from ESPHome and in Settings / Device & Services / ESPHome and delete “esphome-web-9e14e4” Restart and it should be gone.

There is no way to delete it. There is only an adopt button. I went into the terminal and deleted the yaml. then, searched for any file with e14 in it. I deleted everything that came up. When I restarted HA, it came back to life.

I have restored from an old backup now though, so no use trouble shooting with me anymore. I wanted to put it here in case anyone else runs into this.

When you remove (Delete) an ESP device you must remove it in 2 areas. The screen shot where you see adopt (that’s what you did and it’s why it showing adopt again) and under “Settings / Device & Services / ESPHome device and delete”. restart HA and the adopt will not show up again. Just deleting it in ESPHome will not remove the entities/device.

2 Likes

I tried that also for an ESP32 (deleted both in the ESPHome page as well as the integration in settings/devices & services) but a restart still made it show up as adoptable. However as there was a ESPhome update I did that and it went away so I wonder if you need to do an update all for the adoptable device to go away?

3 Likes

Hello, I am a little late jumping in, but I have a similar situation that I have not been able to resolve so far. In my case I have three smart plugs which are working fine, but my ESPHome screen also show these same devices as discovered. If I attempt to adopt them, it fails and I assume it is because these devices are already there!! Although they don’t bother me that much, I would like to get rid of these discovered blocks to clean up the screen and would welcome any suggestions.
esphome

Running into the same issue… restart wont help and reinstalling the esp32 with different firmware will make it juat pop up again and not able to make it usefull again in HA. Does my Pi need to be powered off completly in order to forget the devices? I just want to re-use my esp32 for a different task. Now I’m not even able to repurpose it for anything else…

Same issue here. I’ve tried to install an Atom Echo which appeared to install but doesn’t link to the voice assistant and does nothing (no light) when I press its button. I’ve deleted it in both places and restarted HA but the device still appears as discovered, even when it’s disconnected and has no power source… I then tried to remove and reinstall the ESP Home integration but this just asks me for my ESPHome node and times out trying to connect to my HA server IP address. I’m stuck as to how to proceed.

What’s worked for me is: Following the steps as outlined by @Blacky, remove from ESPHOME and also remove from Settings, Devices & Services, click on the ESPHome line and NOT the ?? devices line. Click on the 3 dots at the end of the line of the offending entry and select Delete.

This has worked for me for several devices, if you don’t remove from both ESPHome gets itself a bit confused, leading to me getting VERY confused!

2 Likes

That did not work for me. I had to completely delete all devices in Settings, Devices & Services. Then I deleted all adopted devices in ESP Home addon. Then I uninstalled the addon and ensured that its configuration files in the /config folder you can access over samba on HA is gone. After than I started over. The newly discovered devices are already flashed and renamed to my names form the default Athom naming.

I believe that I have found a way to do it.

The non-existent device waiting to be adopted will have a name in small letters under the friendly name in large letters.

I went to the directory config/.esphome and found that there was a file matching that name.
I moved it into a folder called trash, and restarted ESPhome. after that, it disappeared.

B.

I am facing the exact same issue, with the exact same device. Trying to get a “voice assistant” from an Atom M5 Echo. Even when the device is UPLUGED, it still appears on ESPHOME to be adopted. I have deleted it from ESPHOME, Settings/Devices, I even went to config.yaml and deleted all files (under esphome) with the name for the Atom Echo 5. Restarted several times, but the device keeps showing up on ESPHOME to be adopted. I cannot do ANYTHING with the device, as if I try to add it, it creates a conflict. I have tried all the provided ways above, but nothing has really worked.

Did you fix the issue?

1 Like

Same issue here.
Anyone report this problem?

1 Like

I am having the same issue trying to edit the configuration of an Atom Echo M5. It works fine with the config provided by Home Assistant. But as soon as I edit the file and install it, a new device (the same) is discovered in addition to the already existing Atom Echo. I then have one offline Echo Atom and the same one with a different name which wants to be adopted. What am I missing? :slight_smile:

1 Like

I may have found the solution! Or rather a fellow Home Assistant user on Discord helped me solve it. You have to remove “the dashboard_import”-part from the config to prevent the device from being discovered more than once. :slight_smile:

Rebooting HA didn’t remove phantom devices for me.
However when I restarted the ESPHome add-on it did remove the entry.

5 Likes

This worked great - strange that a restart of HA didn’t work but a restart of ESPHome integration did. Thanks a ton for resolving this thorn in my side.

Restart of ESPHome Imtegration helped here, too. Thank you for your hint.

In M5 Atom, remove or comment “name_add_mac_suffix: true” work fine for me.

Lol. So I’m guessing restarting HA doesn’t restart the add-ons too?

Since this seems bite a lot of people including me frequently, this probably needs to make its way into future HA versions… at least until this little ESPHome glitch or oddity is resolved:

Add a note to the “Restart Home Assistant” GUI saying this action does NOT restart add-ons, or add a checkbox like “restart all add-ons too”, or “Restart Home Assistant and Add-Ons”.

1 Like