Getting Anran 2K Q01 Camera RTSP Stream into HA - Advice request


I recently purchased the above camera as I thought it looked like I could integrate it with my existing Smart Life setup (and it was super cheap). The app is clearly a Tuya white label, however the setup QR code will not be recognised by SL so I resorted to using their own CloudEdge app.

Everything about the camera is great, and I would now like to integrate the RTSP feed to our wall mounted tablet so people can check in on the camera before opening the door without having to get their phone out.

After many days of tinkering I’m starting to think it’s just not possible but would really appreciate a sanity check or some guidance as to other options I could try as this is not really my area of expertise.

Steps I have taken so far…

I contacted their customer service team about accessing the rtsp feed locally and was given this information.

"Unfortunately we don’t recommend setting up the camera that way or accessing the camera that way as it will not basically work as the camera is not designed anymore to work that way, however, if you really want to try, here are the details below.
User: The username defaults to admin
Password: Password is empty by default
ipaddr: IP address of the device
Port port: 80 or 554
N is the channel number: IPC is 0, 4-way NVR is 0~3, 8-way is 0~7 and so on
M is the code stream number: the main code stream is 0, the secondary code stream is 1;"

I tried using this info in the Generic Camera integration as Stream Source rtsp:// (I also tried port 80) I used the Username and Password option at the bottom of the setup instead of putting it in the stream source as both admin and blank password and also my CloudEdge username and password, I checked the UDP transport protocol as I can see it transmitting on that, but I always get a URL time out.

I have an M1 MacBook so I was able to run the iOS app and watch traffic. I can see the camera transmitting over UDP on port 50720 and then being received on the laptop on port 16685. (Traffic goes via an azure instance in eastus2) so I tried those two ports as well but nothing going doing.

If anyone has any other ideas I would be super grateful to try them out. Or if there is some other info I need I can also try finding that (fairly competent IT person)

1 Like

Got the same camera and by the sounds of the same setup with the same issues.
I’ve also got the same advice from the support chat and also have tried various variation on the username/password. No luck so far
Also tried via the browser on ubuntu however also getting a timeout on the media player

I have a Anran camera that is Solar powered with the same issue. They blocked all the port. Tried using Zenmap on it. I wonder if or since they wont let us access the camera via rtsp, if they will allow us to do a api service from the app that would allow us to integrate the stream into homeassistant

This is I believe the same camera

Yeah, thats the camera I have. I wouldn’t know where to start with an API so it just exists now, patiently watching the front door and waiting for me to occasionally check my cats butt as she hops over the fence!

If anyone does have any luck getting Cloudedge and HA to play nicely that would be ace!

So I may have found something, but I need some folks smarter than I to take a look.

Found all of this on an original post in reddit

@grex23 OH! And it looks like they just created a facebook page. Maybe if we can get enough people to bug them, maybe we can make something happen

Looks like you are already on their case. I saw your note in the comments

The rest of it is a bit too far past my capabilities as well. Nice hunting though

just a heads up for you all. I have also run into the same issue but left them a bad review on Amazon marketplace. They seem pretty keen to engage in dialogue to help me remove the negative reviews even going as far too far for me additional cameras for free

1 Like

Hi! Try it

did you guys manage to get a rtsp feed?

Do these cameras have a web interface with a video feed?

DO NOT BUY THESE CAMERAS!! You can’t access the RTSP and you are not able to access a web gui. Only through the app. If your looking for a good solar powered wifi camera go to LS Vision.