Getting ConBee II to be recognized by HA

Running HA Supervised > Docker > Ubuntu[18.04.4 LTS] (installed using HA official docs as guidance). Was able to get a Zwave USB Stick working successfully, but no such luck with ConBee II.

  1. The CB stick is not recognized using either the HA > supervisor > system > hardware, nor by running “sudo ha hardware info” from SSH CLI.

  2. I’ve installed deCONZ. However it will not start. I’ve reviewed docs for HA deCONZ, and have made the following changes inside configuration.yaml:

# Configure a default setup of Home Assistant (frontend, api, etc)
# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url:
        port: 80

Restarted the service. Rebooted the machine. No change. FYI, on reboot, I get this log message:

ERROR (MainThread) [supervisor.api.proxy] Client error on WebSocket API Cannot connect to host ssl:False [Connection refused

Next, go to Configurations > Integrations > Add New Integration > deCONZ Zigbee Gateway.
Add host IP Address:
Port: 80 (default)

Next popup states the following:

Link with deCONZ
Unlock your deCONZ gateway to register with Home Assistant.

  1. Go to deCONZ Settings → Gateway → Advanced
  2. Press “Authenticate app” button

Couldn’t get an API key

So, I’m stuck, where am I supposed to go from here? I’ve been out to Phoscon’s site, but didn’t find any clues their either.

Are you running the deconz docker container?

From the docs, at this page:

##Recommended way of running deCONZ
An official add-on for deCONZ is available in the Home Assistant add-on store.

Docker was installed as per HA official instructions.

BTW: Ubuntu is installed on an Intel NUC [Intel N4100 Quad-core Processor]

I can only comment on the community container. Since you’re running HA with docker, I would recommend using the deCONZ container as well. I have both running on my ubuntu server and have no issues with them communicating.

Which begs the question. Why do I need to install/run Docker, since there are no other server level applications on this NUC? HA leads me to believe that there’s no other option when running Linux as an OS.

I believe you could install it with python. But I haven’t tried it myself. I’m a pretty big docker fan, so I’ve never tried any of the other installation methods.

On there is a special NUC image. So there are multiple options given.

On the other hand I run HA supervised as explained on that same page (way lower) in docker. And just installed deconz in the supervisor and followed the well written instructions in that addon to the letter. It works perfectly out of the box. So maybe you overlooked something while installing? Maybe remove everything you did and try over?

Is your Conbee II stick connected to a USB extender? or directly to your machine?

Welcome to the forum.

It’s great that you want to help but they’ve probably moved on by now. The last post was a year ago.

Thanks! Hopefully my post will help someone a year from now :grinning:

1 Like

It did, thanks Aaron!

1 Like