Getting Digoo DG-M1Q working on Hassio using FFMPEG

I’m having a few problems, I purchased a Digoo-M1Q.

I can’t work out what port to block in order to prevent the camera to access the internet. My routers UPNP port table doesn’t seem to detect it the camera. I’ve tried blocking port 5000 & 445. I have determined the IP address and given it a static IP.

I can access the video feed through VNC but I can’t get it to work in Hassio.

In Configuration.yaml I have the following code:

ffmpeg:
ffmpeg_bin: /usr/bin/ffmpeg

camera:
platform: ffmpeg
name: Jeffrey Camera
input: rtsp://[email protected]:/onvif1

Errors I’m getting

2018-07-21 20:31:28 WARNING (MainThread) [homeassistant.setup] Setup of config is taking over 10 seconds.
2018-07-21 20:31:47 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2018-07-21 20:31:50 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2018-07-21 20:31:54 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2018-07-21 20:31:59 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2018-07-21 20:32:41 WARNING (MainThread) [haffmpeg.core] FFmpeg isn’t running!
2018-07-21 20:32:41 ERROR (MainThread) [aiohttp.server] Unhandled exception
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/aiohttp/web_protocol.py”, line 398, in start
await resp.prepare(request)
File “/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py”, line 300, in prepare
return await self._start(request)
File “/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py”, line 605, in _start
return await super()._start(request)
File “/usr/local/lib/python3.6/site-packages/aiohttp/web_response.py”, line 367, in _start
await writer.write_headers(status_line, headers)
File “/usr/local/lib/python3.6/site-packages/aiohttp/http_writer.py”, line 100, in write_headers
self._write(buf)
File “/usr/local/lib/python3.6/site-packages/aiohttp/http_writer.py”, line 57, in _write
raise ConnectionResetError(‘Cannot write to closing transport’)
ConnectionResetError: Cannot write to closing transport

Any ideas??

Hi,

if are you still interested, i get this camera working in hassio with this code:
configuration:

ffmpeg:

camera:

platform: ffmpeg
input: rtsp://admin:[email protected]/onvif1
name: camera01

thanks I’ll give that ago. I’ve gave up in the end. I have tried this code but it is no longer showing up on the home page. I can’t remember if you have to call it up somewhere.

Hi,

Thank you for sharing. The ffmpeg setup works fine, but only showing still image, and updates when I refresh the browser.

Did you even get video streaming to work?

The stream component that was added in 0.90 should do this in theory, but unfortunately it doesn’t work with the Digoo DG-M1Q yet. If you try to view the stream, you get an error in the logs: Nonmatching transport in server reply. From what I’ve read, this error happens because the camera only supports the UDP protocol for RTSP. There’s an issue on GitHub to track this: https://github.com/home-assistant/home-assistant/issues/23094

1 Like