Getting DuckDNS to work with encryption

I have been using another pi to gain access to hassio when remote, but would like to safely give it access to the outside .

Instructions say to NOT use Let’s encrypt if you are going to use duckdns as it is built in…but.

Everything went fine until I got to this part:

Use the following configuration in Home Assistant to use the generated certificate:

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
Config checker doesn't like the ssl code and gives me this:

    Invalid config for [http]: not a file for dictionary value @ data['http']['ssl_certificate']. Got '/ssl/fullchain.pem'
    not a file for dictionary value @ data['http']['ssl_key']. Got '/ssl/privkey.pem'. (See /config/configuration.yaml, line 26). Please check the docs at

Do I still need to install Let's Encrypt?


It was Let’s Encrypt , but my stupid mistake of overlooking something very simple:

Overlooked part about agreeing to terms has to be set to “true”

It’s still not working but it generated the keys so those errors are gone now.

Ok I saw others with same issue and their fix worked for me:

Had to disable any port forwarding/upnp that uses 443 externally and map 443 to hassio

8123 to 8123 did not work
8123 to 443 does work.
I really did not want to give up 443 but it does work now.