Getting started with Zwave JS

I’ve brand new instance of HA, I added Aeotec gen 5 stick and that went well.
[To add: I used Zwave JS integration and Zwave JS addon]
As an experiment I tried adding zooz 4-in-1 sensor, after adding it showed only 2 entities : temperature (which always show 0F) and battery (which always show 100%). Other entities are not shown.

So I’m assuming zooz is not added correctly.
I initiated start exclusion pressed zooz button twice, it showed node 5 removed successfully (node 5 was number when added at very first time)

Later I tried add node -> start inclusion press zooz button twice, this seems to go through. However newly added device/node always has manufacturer and model as unknown (I waited almost half an hr and also rebooted HA).

How do I debug / fix this? I want to expand zwave network further but for now just trying to get one sensor working before purchasing and setting up more devices.

Log info (after removing, hard reset and trying to add zooz again)

16:20:21.782 CNTRLR   starting inclusion process...
16:20:21.806 CNTRLR   handling add node request (status = Ready)
16:20:21.806 CNTRLR     the controller is now ready to add nodes
16:20:25.019 CNTRLR   handling add node request (status = NodeFound)
16:20:25.138 CNTRLR   handling add node request (status = Failed)
16:20:25.139 CNTRLR     starting the inclusion failed
16:20:25.140 CNTRLR   stopping inclusion process...
16:20:25.209 CNTRLR   handling add node request (status = Done)
16:20:25.210 CNTRLR   done called for 10
16:20:25.211 CNTRLR   the inclusion process was stopped

After rebooting HA, hard resetting zooz I can get it added but no entities show up:
Log shows

20:17:10.371 CNTRLR   [Node 017] treating BasicCC Set as a report
20:17:18.447 CNTRLR   [Node 017] treating BasicCC Set as a report

Not sure what is needed for entities to show up
Under devices it still shows Unknown

Completely removed ZWave JS supervisor addon.
Installed ZWave JS to MQTT instead.
Excluded the zooz sensor, re-added it.
Let it sit for a day, and it was added successfully.

So I’ve got zooz sensor working, however would still like to know a definitive approach.
Also at this point it looks like ZWave JS to MQTT is way better than ZWave JS for supervisor addons.