Getting this error after updating to 0.74.0

After updating to the last release i get the following error never encountered before:

2018-07-23 12:03:33 ERROR (MainThread) [homeassistant.bootstrap] Error loading /home/homeassistant/.homeassistant/configuration.yaml: Secret allowed_chat_ids3 not defined

I checked all the entries related to telegram and it seems all ok, but also after deleting all the entries related to telegram i still get this error…
Only thing i did was resetting my smartphone.

This looks like you have a notify/telegram option

chat_id: !secret allowed_chat_ids3

in your config, but no

allowed_chat_ids3: xxx

in your secrets.yaml.

Maybe the “3” at the end is a typo?


I deleted all the entries related to telegram in all config files, but i still get this error

Maybe you accidentally left the secret in.
Just search for it in your config file - or files - in case you’re using split config files.
It has to be somewhere - HA is not making it up :wink:


Nothing…, i have NO entries related to allowed_chat_ids or ids3 into ANY config file

That’s really strange then.
Maybe try to define the secret in your secrets.yaml and see what happens then.
Maybe you get an error with a more specific location to look at.


i already tried this… and i got the same error

That’s even more strange. Are you sure you’re looking at the correct set configuration files?
I’d do a system-wide grep for the secret name to see where it pops up:
# grep -rl allowed_chat_ids3 /

Almost out of ideas here…


found… it was inside a package. that’s why i did not find it… solved

Great! Glad you solved the mystery :wink: