Giex smart water valve

Looks like there are two hardware versions with different timezones and other differences:

1 Like

I´ve bought the same water valve but I get nothing out of it. I tried to pair it using Z2M but the device didnt show up. Even in the logs you can`t see a slightest evidence of the water walve willing to pair.

Did anyone have some ideas? I tried to get it in pairing mode by pressing the button for a long time, but it did not seem to be in pairing mode.

Do you need to buy the hub as well as the valve to work with zigbee2mqtt or will the valve on it’s own work?


I just have the valve and it works fine with z2m (no hub). It’s mostly OK, but there have been a couple of instances where a command to close the valve has not been acted upon (it stays open). What’s odd is that if I press the button on the valve in this instance, it does nothing, as if it’s received the z2m command and tried, but failed. I think it’s a problem with the device rather than a zigbee issue.

Thanks. I might have to give it a try.

Hi bob4.

I bought two of them. One works like a charm. The other has the same issue than yours. It lost it’s connection after a day or two. That’s sad because now we are on vacation and the tomatoes rotten up.

Have you solved the problem with the availability feature? When yes, what I have to do. Of not, what have you done with the device?

Mine has stopped working after a few months. Leaks, stopped turning off, now doesn’t even turn on, yet is still communicating to z2m reliably.

The seller stopped responding to my messages a couple of weeks ago.

I have replaced it with an RTX Zvg1 device but the timer cannot be changed from 10 mins and it restricts the flow rate.

The Giex would be great, but they just don’t seem to be built very well.

Did some of you also experience that the water pressure is lower with these devices? Or is there anything i should remove in order to use it right?