GL-C-008P Shows incorrect light color (ZHA)

I have this controller connected to this LED strip.

From what I can tell I have wired it up correctly.

The problem I’m having is the only colour emitted properly is red. When I selected another colour it will either stay red or no light emitted at all. I have tried re-pairing several times.

Actually when I select green it will also show but very dimly (with brightness on full).

Here is the device signature

  "node_descriptor": "NodeDescriptor(byte1=1, byte2=64, mac_capability_flags=142, manufacturer_code=4687, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=0, *allocate_address=True, *complex_descriptor_available=False, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=True, *is_security_capable=False, *is_valid=True, *logical_type=<LogicalType.Router: 1>, *user_descriptor_available=False)",
  "endpoints": {
    "11": {
      "profile_id": 260,
      "device_type": "0x010d",
      "in_clusters": [
      "out_clusters": [
    "242": {
      "profile_id": 41440,
      "device_type": "0x0061",
      "in_clusters": [],
      "out_clusters": [
  "manufacturer": "GLEDOPTO",
  "model": "GL-C-008P",
  "class": "zigpy.device.Device"

Hi, I just bought a GLEDOPTO and it works fine. I had to cross a few wires as they are not mapped in the same positions but the strip should explain which wire is on which LED colour maybe on the back or in a different section of the strip?

You’ve probably either solved this or moved on by now but I had this same exact problem recently. The problem was that I was using a 12v power supply, which was only enough power to light up the red LED. I got a 24v power supply and it worked perfectly.