GL-S10 v2.1 Packet Loss Issues

I purchased 4 of the GL-S10 devices to run as bluetooth proxies. I installed them via official web installer and also directly from the ESPHome dashboard. Both yielding the same result. When I ping the devices I get about 18% packet loss and the logs, etc are constantly dropping their connection. The same issue is occurring on multiple devices. Anyone seen this?

Edit: OTA also doesn’t work because of the significant packet loss.

@blackadder (any thoughts?)


I found my two recently purchased GL-S10 devices would go into a reboot cycle after I configured them in Home Assistant. Not sure if it is the same issue but looked like packet loss to begin with.

Have raised a ticket here: GL-S10 reboot cycle after device configured in Home Assistant · Issue #3819 · esphome/issues · GitHub

Interesting. I’ll have to look at the logs. Are you using Ethernet or WiFi?

I am using Ethernet. Though I have just changed to using wifi and it is working as normal (I haven’t noticed any packet loss).

I just deployed this device, and also found out OTA isn’t working.
Launching a simple ping, I have 20-30% packet loss.

I followed a tip on the related GitHub issue GL-S10 OTA Failure, even with safe boot · Issue #3682 · esphome/issues · GitHub
Fixed the port of my network switch on 10Mbit-full duplex. Now packet loss is almost gone (1-2%) and I am bale to flash OTA.

That’s interesting. Trying two olimex POE ISO boards… both fail when using POE… but work fine with ethernet + usb micro power…

All on Unifi switches.

I think the official may have put the wrong firmware in the website. see there.

Updated to Firmware: 2022.12.1 (Dec 17 2022, 11:40:17) and now working as expected via ethernet.

I’m on 2022.12.2 still broken.

I’m on 2022.12.8 and it’s still broken…

On ESPHome v2023.2.2, still see packet loss

ping $IP -c 200 -i 0.2
200 packets transmitted, 157 packets received, 21.5% packet loss
round-trip min/avg/max/stddev = 0.765/2.021/8.592/1.420 ms

Any updates on this? I just bought this device, haven’t flash it yet…

I just set up one of these devices this week. I was experiencing ≈20% packet loss with ethernet - I couldn’t perform an OTA update, and the integration for the Bluetooth device I wanted to connect to wouldn’t even initialize successfully.

I switched my S10 to a wifi connection, and now I’m seeing <2% packet loss, OTA works great, and my Bluetooth integration actually functions! I wish the S10 worked well over ethernet, but for now I’m happy with wifi.

It’s worth noting that I only have one Bluetooth integration currently, and it doesn’t update states very often. Perhaps if there were more Bluetooth traffic/connections necessary, there could be a noticeable conflict with wifi.

How did you change to using WiFi?

Thanks for letting us know, so since it s working with Wifi, I tried to flash mine. It s a v2.1 version, so layout is slightly different. When I tried to flash using the webtool I can see red and green led from the USB Rx and Tx flashing, but it s stalled in “Preparing” until I have a Failed message.
Did anyone succeeded to flash a v2.1using webtool? Is there anything we need to change?

I flashed 2.1 using the webtool just today and it worked perfectly. I am, however, experiencing the Ethernet packet loss so I’m going to build my own bin to see if that helps.

Thanks for letting me know, I must do something wrong but can not figure it out. Would you mind posting a picture of the cabling for the flash? Are you using specific drivers?

Like you want to know what type of cables I used? I just followed the guide on blackadder’s website:

I have the same issue with the 2.1 board and have resorted to modifying the YAML to connect to WiFi. I suppose I could use docker to compile an older version of the firmware and update my switch to downgrade the port to 10MFD, but I am not sure that still works. Has anyone done this recently?