Glances: unable to connect on installation of integration

I want to monitor an RPi 3 running Raspbian (also one of 2 PiHoles) using Glances. I installed it locally on the RPi3 and it runs fine, as well as starts the webserver. When I connect to it from my Windows PC at its local address ( I get the Glances info - same as running Glances on the RPi directly.

However, the installation and integration info suggests I should be able to access it at:
This just gives me a 404.

As well, when attempting to install the Glances Integration on HA - which is on a different RPi - I can input the Host as the IP above, with the port in the proper spot, but whether I use a username/pass or not I get a “failed to connect”.

I’ve restarted the RPi and reloaded HA…but no joy. Not sure what to try next.

Update: I installed Glances (identically) on an RPi4, also running Raspbian and my redundant PiHole. It failed to connect, then I ran: pip install ujson and it installed version 5.7.0. HA/Glances connected without issue to the RPi4.

Tried the same in the RPi3…it installed ujson version 2.0.3 and it failed still.