GMail Integration no success with installation

I tried multiple times (even with different google accounts to add the Gmail integration, but each time I get error message ::
# Access blocked: Authorization Error
The OAuth client was deleted.

If you are a developer of this app, see error details.

Error 401: deleted_client
Anyone has any idea of what to do ?

Did you mean the SMTP integration?

If so, did you enable less secure apps like it says to do in the documentation?

Yes I tried also outlook.com

Google mail is different from the SMTP integration

That is what I am doing. I have completed the whole Google credential process but at the end I get the error message.

Try making a new OAuth client in your Google API Console and then setting the Gmail integration again.

Thanks. I tried this several times, but will persist.

I got it to work and this was the issue, and it may be helpful for others. As I had tried several times, the Google Authentication, even though it did not work, was in HA and had to be removed. Once removed, and going through the process again, it now works.