Goodwe converter on Domotiz to HA

I’ve got a Goodwe Converter running on an instance of Domoticz and sad to say, my type of converter is not compatible with HA’s Goodwe Integration.

Update 14:45 (02:45pm): my inverter is a GW3600D-NS

However, all is not lost I think but I am just a newbie. Domoticz can send JSON of any Index and if HA can parse JSON, there is a possibility to get these values into HA.

This is an example of a JSON-message to retrieve current power the converter send to the grid and the URL to get it from differs to your personal situation:
the ending of the URL &rid=4 is the Index in Domoticz.

The message domoticz sends back is this:

	"ActTime" : 1710247061,
	"AstrTwilightEnd" : "20:29",
	"AstrTwilightStart" : "05:05",
	"CivTwilightEnd" : "19:10",
	"CivTwilightStart" : "06:24",
	"DayLength" : "11:41",
	"NautTwilightEnd" : "19:49",
	"NautTwilightStart" : "05:45",
	"ServerTime" : "2024-03-12 13:37:41",
	"SunAtSouth" : "12:47",
	"Sunrise" : "06:57",
	"Sunset" : "18:37",
	"app_version" : "2024.4",
	"result" : 
			"AddjMulti" : 1.0,
			"AddjMulti2" : 1.0,
			"AddjValue" : 0.0,
			"AddjValue2" : 0.0,
			"BatteryLevel" : 255,
			"CounterToday" : "3.700 kWh",
			"CustomImage" : 0,
			"Data" : "21027.100 kWh",
			"Description" : "",
			"EnergyMeterMode" : "0",
			"Favorite" : 1,
			"HardwareDisabled" : false,
			"HardwareID" : 2,
			"HardwareName" : "Goodwe Solar Panels",
			"HardwareType" : "GoodWe solar inverter via SEMS API",
			"HardwareTypeVal" : 94,
			"HaveTimeout" : false,
			"ID" : "<DELETED>",
			"LastUpdate" : "2024-03-12 13:33:47",
			"Name" : "Inverter output power",
			"Notifications" : "true",
			"PlanID" : "0",
			"PlanIDs" : 
			"Protected" : false,
			"ShowNotifications" : true,
			"SignalLevel" : "-",
			"SubType" : "kWh",
			"SwitchTypeVal" : 4,
			"Timers" : "false",
			"Type" : "General",
			"TypeImg" : "current",
			"Unit" : 4,
			"Usage" : "1316 Watt",
			"Used" : 1,
			"XOffset" : "0",
			"YOffset" : "0",
			"idx" : "4"
	"status" : "OK",
	"title" : "Devices"

I think A lot of VAR’s can be extracted so that HA can deal with them.
I haven’t got the knowlegde yet to have HA parse all the Variables needed.
I hope someone can help with this so other Goodwe owners can be helped.

The value 1316 in the JSON-MSG is the current power being produced.
The value 3700 value is what has been produced so far today.
The Value 21027.100 is what has been prodcued so far.

Like I said, I am a newbie but I hope this helps others (or even me…)

According the documentation D-NS models are supported, so why not raise this with the integration/core instead of creating a workaournd. The code-owners seemt ot be active so …
If you want a workaround then use tht RESTful integration/sensor, see doc too…but imo your approach is not ideal as it then relies on domticz as well

Screenshot from 2024-03-12 15-37-38

This says there is a problem with my GW3600D-NS

No, it does not say that, it cannot connect because maybe (?) your inverter is on a different (sub) net …did you try to run this in debug mode?

They are on the same subnet, HA is on and the Goodwe on 83

Have you run this under debug mode? Logs often help, the above error hardly

is your HA by any chance on docker, if so do you run the container on ‘host’, any ports involved that may be blocked by firewalls or something? Can you ping the goodwe ip from HA cli?

No docker, I have a HA-Green… I can ping from HA, says CONNECTED. I pinged from HA with the integration

Try to set your HA in debug mode. As you have not yet installed the integration, you cannot do this on that level so it has to be for HA as-a-whole. This will explode the number of records in the log so you have to do this for a shortest of time and then undo it.
For ‘green’ I have no clue if there are other options but the 'regualr way is to go to the config folder and change the logger in configuration.yaml to ‘debig’ (or add one to that file). then restart HA, try to setup the integration until it fails (again) and examin the logs in the config folder …best to create a copy of the file as it will be overwritten with the next restart. Change configuration.yaml back and restart HA again. Fingers crossed if the logs provide anyhitng more informative