Google/Alexa - Turn Off New Entities

Is there anyway to disable cloud from adding new entries to google/alexa by default? I only expose a few things and I have to keep going back to delete entities from the google and alexa configurations.

IMHO this approach is backwards. HA shouldn’t be exposing stuff unless I explicitly ask it to. But then again maybe I have somewhere and don’t realize it?


You can choose what you want (or not) to expose in the configuration. By which method are you connecting HA to your voice devices?

I’m using Nabu Casa to connect to Google Assistant (I don’t use Alexa). Everything is working fine, it’s just that everytime I add any sort of new entity it is getting exposed to Google and Alexa by default. I have to remember to keep going back into the Google Assistant and Alexa config to unexpose them. I only realized because I opened the Google Home app a few days ago and ALL of my entities were exposed.

1 Like

I’m familiar with the yaml configuration for cloud. I had google assistant running before Nabu Casa. I moved over to the UI based configuration when I signed up for Nabu Casa. I thought that was supposed to be part of the point to make things easier and be able to do things on the fly. It isn’t easier to have to remember to keep going back to the Google Assistant every time I add an unrelated new script to my config - because I do that a lot!

So if I’m understanding you correctly, the only way to stop entities from being exposed to Google automatically is to set up the configuration manually? If this is actually the case I personally strongly feel like this was a poor design choice. Entities should not be exposed to a cloud service by default. The user should specifically have to activate them.

I guess it’s back to a manual config for me unless they change this. Thanks for your help Marc.


Welcome to the joys of configuring homeassistant. It’s a complete mish mash mess between UI and yaml at the moment.

I’m struggling with the same thing. There must be some cunning way to default to “off”.

If there is I haven’t found it. I ended up going back to a manual configuration. You can still see the entities in the cloud config, you just can’t enable or disable them.

1 Like

Still no solution for this? I just got this all setup and cleaned up all the devices in Alexa. Now everytime I add something to Home Assistant it’s dumping it in Alexa automatically. Not only does this mean we have to go back to the Exposed Entities page, but also to Alexa app to delete the device that was added automatically. Would be awesome if someone could point us to a config option somewhere to turn off the auto-exposed setting.

Thanks to the community btw, I’ve found a BUNCH of helpful stuff here already and really appreciate it!

1 Like

I’ve been on the UI setup for awhile, lately annoyed about it auto-adding new entities… I feel like that should not be the default. Forgot about the YAML setup, going back to that for sure… so tired of toggling off new things and then removing them from the Alexa app (because I forget Alexa web UI is way faster)

Hopefully this can be changed, toggling entities in the HA UI is fast and easy.

1 Like

+1 for being able to turn on and off auto adding entities. Soo annoying having to edit either yaml or the device list in the GUI

1 Like

This is such a pain for sure
Has anyone raised this as a bug/enhancement?

Also, how do you do it via yaml, in the manual format you mentioned?

Scroll down to manual configuration.

Also, vote!

If I’ve disabled an entity from the Nabu Casa Google interface, how can I re-enable it? It no longer shows either exposed or not exposed … now hidden. I was trying to manage some duplicates so google doesn’t turn of multiple lights which are the same as it just sounds ridiculous to turn multiple things on or off when there’s only one.

On my entities view outside the cloud view (the main entity) grid, I cannot get things to re-enable.