Google Assistant aliases not working

I have Google Assistant setup with HASS.IO and working correctly for the most part. I can turn on a light by saying “OK google, turn on front door”. It turns on the entity light.front_door. I’ve tried to add some aliases so I can say other things instead of front door…such as front light. In my google assistant app I can see the first alias used, and if I say “front door” google will respond with “front light”. However, if I say “OK google, turn on the front light” it says that it’ll do it but nothing happens. Here is my setup:

  project_id: !secret gass_project_id
  client_id: !secret gass_client_id
  access_token: !secret gass_accesstoken
    - switch
    - light
      name: "Front Door Light"
        - front light
        - front door light
        - front door

Any idea why “Ok google, turn on front door” works and “OK google, turn on front light” doesn’t? I do not have any entities that are front light.

Unfortunately that wasn’t my issue. I rebooted the Google home for the fix and got it responding again, but still not working with the aliases… only “front door” in my case. “Front light” says it’s turning it on, but nothing is happening.

got cloud component enabled ?

It might be a Google Keyword. I think you’ll find this is a Google issue not HA. I have had to change my shortcuts a few times because of this. (I use shortcuts instead of aliases)

This was the same for me, the aliases did not seem to work. I ended up using shortcuts in the Google Assistant app instead.

I ended up having to restart HA to get my mini working properly as a media player again as well.

Thanks for the replies. I tried a few more things last night like listing the aliases in a single line list (i.e. [“front light”, “front door”] but that didn’t work either.

Looks like I’ll just set up a bunch of routines (shortcuts are going away). Is there any way to just replace single words instead of having to make a bunch of routines for both on and off?