Google assistant and multiple switchbots

hi All,

hope you all are being safe :slight_smile:

background on issue.
using: HassOS 4.11
Device: Raspberry Pi3
have 1 existing switchbot that works google assistant.
shows up in google home app as a fan icon.
can turn it off/on from google home app.

added new switchbot.
from homeassistant web page i can activate the the both switchbot.
from google home app the device is there but i cannot activate it.
i tried using voice command but i get the ’ device is not setup on the google home app’

i notice that on the google home app, when i click on the 1st switchbot, i’m able to get the status fast. on the 2nd switchbot i get a not responding.

i cant figure out where i messed up. hopping someone can point me in a direction.
thanks in advance.

well, i think it fixed itself.
i think what happen was i connected the google home app before restarting the home-assistant.
i added 2nd switch-bot config to the device. i rebooted and tested it through the web browser. i had restarted the device a few times during my first half of testing. after which i went to eat lunch.
came back, comment out the switch-bot config.
restart home-assistant device. when i checked the google home app now showed the device as a light bulb.
un-comment the switch-bot config.
restart home-assistant device.
used the google home app , and it works now.

so i’m not too sure what happen.
i’m suspecting that google assistant will take some time to register a new device properly.
i didn’t check the google home app when i came back from lunch, only after i restarted the home assistant device was when i checked the app.
it also could be due to me restarting the device again.

thanks for reading the long post. :blush: