Google Assistant Component configuration woes

I am struggling with the Google Assistant component (link.

I do not have a Google Home device, but am led to believe that this component will allow me to use Google Assistant (“OK, Google”) on my several Android devices to control some of my home via Home Assistant. So first off, please someone let me know if I am wrong in that use case.

I went through the configuration described in the link above and towards the end I here is what happens. I get to the part where on my Android device I open the Google app and navigate to Settings -> Google Assistant -> Assistant -> Home control -> press press plus button to add new device. And here is what happens:

  1. I find the device called “[test] my test app” and select that
  2. I get sent to my browser and am presented with my Home Assistant authentication page and enter my user name and password.
  3. I get sent back to the Google Assistant configuration and see a very brief message flash at bottom of screen that says “Successfully linked your [test] my test app”.
  4. However, nothing new shows up under devices in Google Assistant
  5. No commands seem to be working through Google Assistant (though I admit I have no idea exactly what voice commands are valid here. As you see in my config I’ll paste at the end, I only added one entity, called “worklight” in order to test this concept. So on my Android device I am trying “OK, Google, turn on worklight” and nothing at all happens.

I am uncertain where to look next for troubleshooting. Any help would be greatly appreciate.

project_id: hass-rks1
api_key: AIzaSyDJSdvE_H2g1DjwRnm7GY9X0UcaXKEYfZ8
name: Worklight

(I don’t know why but the leading spaces are not showing up correctly above, but indentation is NOT the problem, it is formatted correctly on my system and I get no errors/warning when checking the config files.)

Looks like it’s setup correctly. Do you see the device in the Google Home App? Perhaps add expose: true to the light config.

I had the exact same error the other day though… Google couldn’t control anything but the successful link message. I am using an Intel NUC and it runs a script that updates the duckdns IP address for IPv6. When I checked at duckdns, it was actually updating the address to an internal non-routable IP address. Once I fixed that it started working again.

@DavidFW1960: Thanks for the reply. No, I do not see the device in Google Home app (I see a couple of other devices there which were already integrated but nothing new shows up when doing this integration). This was my first clue that something here isn’t working despite getting the message saying the account linked successfully, though I don’t yet know what the process looks like when it is successful.

Based on your comments I did check out my DDNS provider (Google Domains) but I can’t identify anything amiss there.

So I am still stumped, I am afraid.

I also tried connecting my phone to each GH device - So enable BT on the device and then BT on iPhone and it connects and I get the IP & MAC in known devices but since then, it’s only if I go back into BT settings on the phone will it connect. So they all show not_home… I seem to remember it didn’t always do this… maybe it’s a 0.91.x/0.92.x bug?