Google Assistant - Configuration issue

hello everbody…

I am trying to setup the Google Assistant integration, but I have a challenge on following he instructions:

The sample configuration file below, have a parameter “SERVICE_ACCOUNT.JSON”, but I am not too sure there should I put this JSON file and/or if it is system generated…

# Example configuration.yaml entry
  project_id: YOUR_PROJECT_ID
  service_account: !include SERVICE_ACCOUNT.JSON
  report_state: true
    - switch
    - light

I have included the code above in the configuration file, but when I “check the configuration file” it throw an error on that specific parameter…

can somebody help me please?

Thank you


I had a bit of an issue with that as well at first.

The JSON file is downloaded at step 2.6 just above the configuration section of the docs you’re referencing. The default name will be something like: [your-project-id]-[part_of_key].json and it lives in the same directory as your configuration.yaml