Google Assistant Error: "required key not provided"

I followed the The google_assistant setup. My config is:

#Google Assistant Action Integration
  project_id: [My project ID]
  client_id: [long URL safe random string]
  access_token: [a different long URL safe random string]
    - switch
    - light
    - group

When I try to restart my home assistant with the new config, I keep getting this error:

2017-10-28 10:19:48 ERROR (MainThread) [homeassistant.config] Invalid config for [google_assistant]: required key not provided @ data['google_assistant']['access_token']. Got None. (See /home/hass/.homeassistant/configuration.yaml, line 121). Please check the docs at
2017-10-28 10:19:48 ERROR (MainThread) [homeassistant.setup] Setup failed for google_assistant: Invalid config.

However, when I go to the google home app try to add it, it takes me to my home assistant page

I am running AIO version of HASS on my RPi3. I have my DNS through Duck DNS, encrypted via Lets Encrypt.
Port forward 433 > 8123

Things I already did:

  • Made sure the Project ID matched the one found in the Project settings
  • Made sure my clien_id was the same in my config and the google actions page
  • Used the terminal command provided in the setup to generate both the client_id and access_token

Any help would be appreciated :slight_smile:

so, it’s something like:
project_id: haxxx-x00xx
access_token: abcde123abcde123abcde123abcde123abcde123kljdshflksjbdhlfksagfljb
- switch
- light
- group
- scene


There shouldn’t be at the end of the Client_id. where did you get that from?

but everything else is correct!

try here:

So I noticed that I had a typo… access_toke instead of access_token
Now it works perfect!

Thanks for the help though!

1 Like