Google Assistant - google_assistant.request_sync service

I just set up Google Assistant, and it is working great. The only thing I am hung up on is enabling the google_assistant.request_sync service by adding the API Key (step 9 here I’ve followed all the steps, restarted several times, etc, but google_assistant never shows up as a domain on the services tab.

I read through the big GA threads, and saw a couple posts with the same issue, but didn’t find a resolution. I am not getting any relevant errors in the logs either. Anyone have any ideas?

Here is my GA config for reference:

  project_id: redacted
  client_id: !secret google_client_id
  access_token: !secret google_access_token
  agent_user_id: redacted
  api_key: !secret google_api_key
  expose_by_default: false
    - switch
    - light
    - group
    - script
    - cover

Which version of Homeassistant are you running?


I didn’t even think to check the version changes! I see now that request_sync was added in .58. Whoops!

I add my question to this because it’s on the same topic.
I run HA version 0.62.1, I did what it takes to have the google_assistant.request_sync service, it now appears properly in the services list and can be called but… it doesn’t seem to work!
I changed some stuff in the config files, added some mqtt switches, deleted others, so I wanted GA to be connected to the new stuff, this is what the request_sync service is for, isn’t it?
I called the service several time, waited, nothing happen. GA still control my unchanged devices, but doesn’t work with the new one.
In the cloud console, under the API credential tab, it actually list 3 keys:

  • Server key (auto created by Google Service)
  • Browser key (auto created by Google Service)
  • API key 1
    I used API key 1 in my configuration.yaml file, is it correct?

I’m in the same boat. Trying the other 2 keys now.

Still no luck. I even deleted the keys and created a new one.