Google Assistant - How to expose Scenes, Automations and Scripts?

Heya,

I’m trying to expose some of my things from HA to my Google Home Mini’s.
For now, light and switches are doing great and it actually also looks like it accepted my Vacuum cleaner as well.

What I can’t get working is my Scenes, Scripts and Automations.
Is this possible or would I have to create input_booleans to trigger those kind of things?

Here is my configuration:

# Cloud
cloud:
  google_actions:
    filter:
      include_domains:
        # Scene
        - scene
        - script
      include_entities:
        # Lights
        - light.led_tv_light
        # Switches
        - input_boolean.disable_motionsensor_backyard_automation
        # Media Players
        - media_player.living_room
        # Temperature Sensors (I know this one aint working)
        - sensor.temperature_xxxxxxxxxxxxx
        # Vacuum
        - vacuum.xiaomi

Thanks :slight_smile:

1 Like

have a look at the docs:

Scripts and scenes are supported domains, automations aren’t

1 Like

That’s the same page I found. I was missing the automation part though. But why can’t I see the Scenes then?

If you look at my config, what did I then do wrong?

I’ve not exposed my scenes nor scripts so no idea how they would show up in GA, but on the basis that they are not devices with multiple states, there’s a chance they won’t show up in your device list. Guess you need to try a “hey google turn [scene] on” to see if it works first.
If it does, try and figure out (if you want) where they show up in GA, but on the basis that it works, I guess it works?
You config appears ok at first glance

1 Like

Some weeks ago the Google Home App changed how scenes are displayed. Good chances that they are already exposed to the Google Home App but you don’t find them :wink:

Go to: Open Home App, choose the rightmost icon (person) -> tap “settings” -> go to the “Home” Tab -> look if you can see the scenes somewhere around there

Unfortunately I can’t see them, but as stated they are being exposed.
I can now say ‘Turn on Scene’ and then it activates nicely.

That’s all I need to know. Thanks guys!

2 Likes

just for interest: you can look if you can see the scenes in the Routines settings:
Create a new routine -> choose popular actions -> control scenes (under smart home). They should be visible there.
Also makes the commands nicer (“It’s movie time!” -> turn on the scene “movie time”)

3 Likes

I can’t because routines are not enabled in my country at the moment :frowning:

Scenes are listed under rooms on mine and also under seemed but not in the home app - only in the Google Assistant app under Home Control and I can control them by voice but you don’t get an icon for them in the Home app.

To clarify this; after looking around I finally found where the scenes are presented. It is really confusing how Google manages scenes in the home app.

You can see all scenes currently present:

  1. Go to Google Assistant Settings
    a) open Google Assistant -> tap the compass -> tap your avatar -> choose preferences in the popup
    b) open Google Home App -> tap the avatar icon (the rightmost) -> tap settings
  2. You will see this window:
  3. Tap Assistant tab -> choose the “Home Control” (light bulb icon)
  4. under devices you should see all Hass.io devices including scenes
    If you want you can add these scenes to rooms by tapping on the scene and choose “room”

Only if you added the scene to a room in this view they are visible in theHome Tab under the room. If you don’t , they won’t show up under “other devices” (lights and switches for example are displayed even if they are not added to a room)

source of images: 9to5google

Hey, @capstan1, thank you very much! I found my scenes. And I found out how to make them visible in all Home tabs of Google Assistant. All the devices HAVE TO BE moved to rooms! All of them. After all the devices added to their rooms - devices becomes visible everywhere.

1 Like

In the past I was able to assign my scenes to rooms (needed so that other houshold members can see them) but now it seems google assistant has updated/changed to where the scenes are no longer available to be assigned to rooms.

When I go to google assistant settings > home control it only shows me the linked services (and new ones to add) and a number of devices under each service but I’m not able to see the individual devices/scenes.

When I go to Google Assistant Settings > Home (tab) > I can see my rooms listed and the devices under each room. In this view it shows the scenes I’ve already assigned to rooms (back when the feature existed) but when I click the cog for the room to select devices for the room it doesn’t show the scenes as an option (it doesn’t even show the existing scenes in this view).

Am I missing something? If Google has removed the ability, is there a way from home assistant to assign scripts (which Google assistant sees as scenes) to rooms/areas?

1 Like

I’m wondering this too - I can’t find any way to expose the “scenes” to the google front end.

I’ve made a script. it just calls a service “notifiy…” to send a notification to my smartphone.
I then looked a home assistant cloud, to make sure it is listed under exposed entities.
(don’t know for sure the english names, cause I use HA in dutch)
Then, I sync’d my devices (ok google, sync my devices). I couldn’t find the script name in the home app afterwards (also routines are not activated in my country). But, I can start the script by sayin "Ok google , Activate ‘MYSCRIPTNAME’ ". I didn’t test much, but the notification was received in my smartphone… :slight_smile:

1 Like

Probably you can expose scenes/scripts in Google Asssitant Settings -> Routines.
In Routines get into Custom.
In the “Assistant will” section, you will find “Adjust scenes”.
If you don’t, go Add action -> Browse popular actions and you will find “Adjust scenes” there.
Press on the setting(wheel) icon for Adjust scenes, and you will find the scenes that you have
made via hassio.
I haven’t tested yet, but I believe the scene would work by making Routines that would trigger the scene.

Assigning scenes to rooms is sometimes possible by relinking account several times via Google Settings -> Home control -> test application.

Maybe it’s really old news but now the scenes are automatically added to google without setting anything

1 Like