Google Assistant -- failed: 404

I can’t find any recent info on the sync issue in Hass

I get the following in the logs when I try to sync

Request for failed: 404

2022-12-16 21:50:46.863 ERROR (MainThread) [homeassistant.components.google_assistant.http] Request for failed: 404
2022-12-16 21:50:46.865 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [140287220352192] Unable to sync devices with result code: 404, check log for more info.
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/", line 200, in handle_call_service
  File "/usr/src/homeassistant/homeassistant/", line 1745, in async_call
  File "/usr/src/homeassistant/homeassistant/", line 1782, in _execute_service
    await cast(Callable[[ServiceCall], Awaitable[None]],
  File "/usr/src/homeassistant/homeassistant/helpers/", line 213, in handle_service
    await service.entity_service_call(
  File "/usr/src/homeassistant/homeassistant/helpers/", line 678, in entity_service_call
    future.result()  # pop exception if have
  File "/usr/src/homeassistant/homeassistant/helpers/", line 943, in async_request_call
    await coro
  File "/usr/src/homeassistant/homeassistant/helpers/", line 715, in _handle_entity_call
    await result
  File "/usr/src/homeassistant/homeassistant/components/button/", line 116, in _async_press_action
    await self.async_press()
  File "/usr/src/homeassistant/homeassistant/components/google_assistant/", line 51, in async_press
    raise HomeAssistantError(
homeassistant.exceptions.HomeAssistantError: Unable to sync devices with result code: 404, check log for more info.

I’ve also tried the following

but this gives the following response

  "error": {
    "code": 404,
    "message": "Requested entity was not found.",
    "status": "NOT_FOUND"

Other than that, Google Assistant seems to work fine and it able to control my devices.

any ideas?

I had the same issue

It started with the expiry of the secure web certificate and ended up changing too much parameters. Anyway got stuck with above error until I grabbed my Google Home app and adding Home Assistant as a device again. Hope it helps you out.

1 Like

I have the same error. Al devices are in the Google Home app Offline. Did a resync. Created a new service-account. Everytime the same error. I don’t use GoDaddy certificates but Let’s Encrypt with a HAProxy.

So did you allready try to link to HA again, this can be done in the Google Home app (same like you link to Spotify for example). Or add a new device, I’m not sure anymore - I think HA was detected and visible in the Google Home app and I was able to add it again.

Yeah all ready did that.

This gives the same error:

curl -X POST -H "Authorization: Bearer KEY" \
  -H "Content-Type: application/json" \
  -d @request.json \

  "error": {
    "code": 404,
    "message": "Requested entity was not found.",
    "status": "NOT_FOUND"

Check the list of entities you added to Google most likely one no longer exists so you need to remove it before syncing.

Did a test with one device synced. Same issue. When I hit the Synchronize Devices button in HA same issue.

Kan service button/press niet aanroepen. Unable to sync devices with result code: 404, check log for more info.

Finally resolved the issue. My Pfense/PFBlockerNG did block

1 Like

That worked for me thank you!

Hi Noenes

you write that you have opened for IP on your pfense.
How did you find out, that it was this ip range you needed to open up to?


Looks like a bad idea and the block is /16, not /24:

Hi thks for the idea, not the problem. However after trying different setups, I made it work, thks anyway