Google assistant IFTTT and duckdns


#1

Hello.

i am trying to set up Google Assistant on my pixel to turn my Tradfri lights on and off With this guide.

i created my duck dns server and can connect to my control panel at this link “http://my-dns-server.duckdns.org:8123”.
I can connect to that link from another network.

i have forwarded port 80,433 and 8123 on my rasberry

But when i type “https://my-dns-server.duckdns.org” i get nothing.

When i say my phrase to the Google Assistant she responds with the right message so i assume the ifttt applet is working but i’m missing something.

Thanks !


#2

HTTPS will only work if you have set up a certificate in your configuration.yaml under the http setting. If HTTP works you can just use that. This is based on the assumption that there was not a typo in HTTP/HTTPS

… “http://my-dns-server.duckdns.org:8123” …

and

… “https://my-dns-server.duckdns.org” …

You shouldn’t be able to access Home Assistant with “https://my-dns-server.duckdns.org” as the service is listening on 8123 by default, not 80, so that is completely normal.

Please note, if you are using HTTP, all communications to and from Home Assistant will be visible in plain text; meaning someone may be able to exploit your internal network and ruin your day.

There is no need to assume the applet worked, as you can click on My Applets, click to edit your applet, then click on “view activity log” to see if it actually was triggered.

Lastly, did you check to see if am message from IFTTT was received on Home Assistant?