Google assistant integration manual setup needs port number

In the manual setup doc for google assistant integration, it is mentioned that you need to input an externally available address for HA along with port number ( Add your Home Assistant URL: https://[YOUR HOME ASSISTANT URL:PORT]/api/google_assistant)

I have my home assistant setup served externally via traefik and use subdomain of my main cloudflare domain to access HA. However no port number is necessary for this access. Will it be an issue if i just replace [YOUR HOME ASSISTANT URL:PORT] with my subdomain and domain (with no port number)?
Thanks

The port is only needed if you don’t use the default port for https (which is 443).

You’re using the default port, you don’t need to specify it.

Excellent, thanks I’ll try setting it up tonight.
When I try visiting the link (https://[YOUR HOME ASSISTANT URL:PORT]/api/google_assistant) with my subdomain inserted, it says 404 page not found though. Is this because I have to set up the Google project first?

Well, you have to set up the google_assistant integration (and restart HA) first.

Even then it requires POST rather than GET, which your browser uses.

I’ve followed all the steps for manual google assistant integration setup but when i got to the google home app to add the [test] Device, i find the device but when i go to add it, it brings me to the login screen for HA but when i login and add my 2fa code, it says 'cannot reach [test] <Action Name>

Any idea what might be going on?