Google Assistant integration, Nabu casa or manual


So I have a HA installation running in docker container, version 2022.2.9.
I’m using the Nabu casa cloud to integrate HA in google home, and it’s been working fine (most of the time).
Now I’m trying to help some friends with their Google home integration, but Nabu casa fails to link with google. Both setups run the latest HA version now, but the same issue has persisted over the 3 previous versions.
Worth to mention, is that they are both running the Nabu casa cloud in trial mode, at the moment.
I figured that this may be to some outtage or problems with the Nabu Casa cloud, so I tried to setup google assistant manually. Also this results in the same behaviour as with nabu. I press either the nabu or (test) integration in GH, redirects to HomeAssistant for login. After login, toast messge stating that account is linking, then pops back to the same menu for choosing integrations to link. Home assistant doesn’t show up in the list of connected devices :confused:
Have read almost every post on this forum regarding similar cases, and tried the tips, but without success. Are there any recent issues with the manual GA integration or Nabu Casa, that you know of?

Best regards

Tried again today, and now it works, using Nabu Casa! :slight_smile:
Did exactly the same as before, so maybe something has been done with the cloud service?