Google Assistant integration not working for other users (my wife)

Howdy y’all!

I’ve successfully set up the + Google Assistant integration, and can now control my devices through my Google Home and Mini. I also linked my wife’s Google Assistant account with (through the Google Home app on her Samsung Galaxy), but when she tries to use the integration (for example to change the state of our Xiaomi gateway light) the Google Assistant responds with a “Sorry, I couldn’t reach” or something to that effect.

Here is what we have tried/observed:

  • I have tried both the Home Assistant Smart Home skill (through the cloud) and the manual Google Assistant integration setup, with no noticeable difference in results.
  • I have tried to link to her Google account through the Google Home app on her Samsung Galaxy as well as my iPhone, again with no difference in results.
  • My default Google Assistant voice is male, hers is female. Sometimes, our Google devices mistake her for me, and the male Google Assistant responds to her the way we expect him to. This usually happens in the early morning, when my wife’s voice is a little raspier than usually (much to my amusement and her chagrin). :smile:
  • If I have just issued a command to our Google devices, my wife can sometimes “piggyback” off of those commands and get a streak of positive responses. However, as soon as the Google Assistant “recognizes” that she’s the one speaking, it’ll switch to the female voice and give the same “I can’t seem to reach right now” response.
  • The only positive response she has received is when she asks Google to “sync my devices”. The Google Home/Mini will then respond “OK, syncing devices for” in the female voice.
  • I’ve tried to see if we can modify the settings in her Google Home setup to ignore her voice profile when issuing related commands, but without luck. I might be missing something here, though, since the Google Home app tends to be somewhat unintuitive to navigate if you ask me.

From our experience, it definitely seems like the issue has something to do with the voice profile setup in her Google Home account. I’m running out of ideas on how to solve it, however. Any help or suggestions would be very much appreciated. :slight_smile:

Google home is not working for google assistant component for me.

Google assistant on the phone works.

Look like issue on google cloud

Hi Jolinn

No advice I’m afraid but i can report a similar problem. My integration was working happily until I added my wife so she could operate our front gates. I installed the integration on her Samsung via Google Home and it all works fine for her. But since then it is no longer working for me. I hear the same message or variations on that theme “it looks like is unavailable right now”.

Keen to see if you get any more helpful replies!

Same problem here. Manual Google Assistant integration worked fine for control of Hue lights up until I updated Home Assistant from 0.73 to 0.77. Now my wife gets a “power controls not yet supported” error from Google on both her phone and our Google Home Minis.

Possibly related to the new auth structure?

EDIT: I decided to go ahead and try step 7 of the Google Assistant manual setup (previously, it worked fine without it). Wife now gets a “couldn’t reach [home assistant action name]” error from the Minis, but it works from her phone. Additionally, if she does her best Batman impression so the Minis don’t recognize her, it also works fine.

I can confirm I’m seeing the same thing as well.

Also, this started randomly with no changes on our end. Was working fine then yesterday it stopped working. It appears to only work for the person who first links to google home. I found this out by unlinking one of our minis and relinking with my wifes account. now it works for her and not for me.

I also tried using the home assistant cloud setup rather than the previous account linking method with the same results. Every time the “other” (non primary) user is told that google home cannot connect to It works just fine from that user’s phone.

Same for me. Appeared 2-3 days ago. I also have two google accounts linked to the same home assistant cloud account. I only see the error on my google account (not my girlfriends).

I can however turn on a group (or if its a complete room in google home, I’m not sure since they are named the same). But not any individual light.

When I use the routine “Okay google, Good night” it can turn of the bedroom (configured by individual lights).

When I try to turn on or change any individual light / switch, Google home replies with either “it looks like is unavailable right now” or “sorry i couldn’t reach”. It works without problems for my girlfriend. She has the male voice. I have the female voice.

Maybe it was a problem with HomeAssistant Cloud or Google Cloud as I have changed nothing and it is now working again. I did like Jolinn’s idea of having different google assistant voices for him and his wife, I was planning to steal the idea but I don’t seem to be able to change my google assistant voice. In the menu where the option should exist it is missing. Odd. Possibly not available outside the US?

Confirmed working again here as well without further changes. Not using Home Assistant Cloud, so I’m leaning towards something wrong on Google’s end.

Regarding the different Google Assistant voices, it is language-limited and initially rolled out for US English users, so it may not be available for you yet.

Here is update from google support. The steps fixed mine

This is xxxxx a specialist from the Google Home Team.

I’m sorry to hear you’re having issues controlling your Home Automation devices with Google Home. Our team is aware of the issue and are working on a stable solution.

In the meantime, please try the steps below if it make any changes:

  1. Unlink all accounts connected to Google Home

  2. Relink all accounts to Google Home

  3. Do a test command to control your Home Automation devices

1 Like

Thanks for the update tyjtyj. I wonder if Jolinn’s issue has also resolved by itself or if the fix from support might help him? I’ll keep this in the back pocket anyway. I didn’t want to unlink unless essential as I have defined rooms for my devices in Google Home and I assumed they would be lost if I re-linked the accounts.

I had previously tried to go through the steps listed by tyjtyj, but without results. However, a couple of days later the issue resolved itself without any further action on my part. Perhaps it was simply an issue on Google’s side, as it seems to have been resolved for other users around the same time.

Confirmed, this seems to be an issue with Google, and its 2020 now and its still not solved :smile:. But Unlink and relink worked well and now both users can connect for myself and me julie

Although it’s not a solution, inspired by this amusing batman story, I found what’s working for us (to allow my wife to invoke HA scripts from the Google home devices):

From the Google Home app of the person who’s getting errors:
Profile icon > assistant settings > voice match > scroll to the bottom and press the X button on each device: this will prevent the Assistant from recognizing the voice of the person on those devices and will therefore execute the routine as if called from the main user’s account.

I have the same issue. What do you mean with “unlink and relink”? If I disconnect every account from home the home itself get deleted and I have to reconnect every single device
Is it right?

I didn’t have any device in that manu because me and my wife use only our own phone to control google assistant. Is there anything else she can do (she has the same issue described in the topic)

I have the same problem I can control devices from my account but my girlfriend is out of the loop. It’s 2022 do we have any solution for it ?

My wife and I were having issues where she could control most of our devices through Google, but some would only work for me. I’ve unlinked and re-linked the HA account several times (as someone else suggested above), and I think that might be what caused my issue in the first place. I finally went into the Google Home app to edit a couple of the devices and saw that under the “Home” setting it just shows “Add to a home”. So I used that to add it to the only “home” I have setup with Google and then they started working for my wife too immediately afterward.

I tried everything suggested here, and nothing seemed to work. I even unlinked HA and created a new project from scratch and nothing.

In case it is worth to someone, at the end the steps from @tyjtyj do work, but you have to make sure to not only unlink all accounts (go to Settings and remove all linked accounts to that house), but also remove All houses (specially if you had multiple homes like in my case).

Then, creating a new home reimported all my devices, and I shared with my wife the house again, and everything is back to normal after almost a month without being able to use voice commands :sob: :pray: