Google assistant linked but no devices show, specifically covers

I’m having trouble getting any devices to show up in my Google Home app. When adding a [test] account I get "Successfully linked your [test] " it then goes back to Home control devices menu but nothing shows up. I set up Google assistant as per and double checked against

I’m specifically trying to add covers, a Fibaro Roller Shutter, called: cover.living_curtain_left_level. Actually I just want anything to show up to prove that my config is actually working.

  project_id: <my project>
  api_key: <my key>
  expose_by_default: true # trying to get anything to show up.
  exposed_domains:  #trying to list anything
    - switch
    - light
    - group
    - scene
    - cover

I’ve tried without exposed_domains with expose_by_default. Without expose_by_default with exposed_domains. I’ve added extra entity_config: with expose true. But nothing shows.

I’m wondering how I can troubleshoot what is happening, are there logs for this connection attempt on either the Google Home app or Home Assistant? I’ve checked out home-assistant.log which has nothing. Can I test what is being exposed without Google Home?

Any help is appreciated.

I don’t know of a way to see which devices are exposed to google
But i know you have to call the google_assistant.request_sync service everytime you add/remove devices from home assistant.

I guess you added the changes after you linked your account?
Then please try to call the google_assistant.request_sync using the web ui and on the sidebar the remote symbol.
Then reload the google home app and there should be something

So while it says "Successfully linked your [test] " on the Google Home app, nothing at all shows up in the list including the [test] account, which isn’t there in the linked services. It still shows in the “Add new”. Doing a sync on the Google Home side, doesn’t have this service listed. Running a “google_assistant.request_sync” on the Home Assistant fails with a “aiohttp.client_exceptions.ClientResponseError: 404, message=‘Not Found’” and a “aiohttp.client_exceptions.ClientConnectionError: Connection closed” but I guess because it wasn’t set up right in the first place.

I saw others had posted in the forums with the same problem, but their issue was they had uppercase letters for the exposed_domains. I have the same symptoms, so guessing it is relating to the way I’m trying to expose my cover devices.

1 Like

What devices should be exposed?

Have you tried entity_config as well and listing the entity and room? Here is part of mine:

# Google Assistant
project_id: !secret ga_project
api_key: !secret api-ga
  - light
  - scene
  - input_boolean
    room: lounge room
    room: dining room

Also if Google doesn’t find any entities when you link the test app in Google Home it’s not added.

So I have a number of covers, for curtains. I’ve tried different combinations like the below without luck:

      name: Curtain_Left
      expose: true
      room: Master Bedroom
      name: Living Curtain
      expose: true
      room: Living Room

Same poblem here…

I tried using below config, save and reboot. it works


project_id: home-assistant-c227d
expose_by_default: true
api_key: AIzaSyDvYEY0Y5EhhMx97yRGqVnilY6Jr5HsKOU

Don’t post your personal project and api…

Thanks David.
Noted sir.

I’m a newbie. need guidance from you and others.

Thank you