Google Assistant Manual Integration ("Sorry, it looks like that device hasn't been setup yet...")

I am seeing Google Assistant integration intermittent response of “Sorry, it looks like that device hasn’t been setup yet. You can do that in assistant settings.”

However accessing HA directly via it’s URL over SSL via WAN works great or if I directly use the Google home app, it works perfectly for turning the switch on/off, no lag etc.

If I ask Google assistant I get the response above about 80% of the time. Funnily enough if I add a routine in Google Assistant app with a defined phrase of “turn on my outlet” and another “turn off my outlet” it never fails to do as I ask.

Is there something I can check in HomeGraph API on google’s end or any enhanced logging I can enable to see why it’s doing this. I’m sure it isn’t a connectivity or SSL issue as it works flawlessly through home app, routines, or home-assistant URL via WAN access.


I’ve had plenty of “can’t reach the test app”, but only rarely get “hasn’t been setup yet” when it misunderstands me. You can check what it actually heard in Google’s My Activity page as described here.

I’ll check but that’s the odd thing. I can just keep saying “turn attic outlet on” or “turn outlet on” and it will work. Then sometimes that exact voice command yeilds the aforementioned response. Additionally, if I make up a command that isn’t a device I’ve ever set up I get a different response.

For example I had configured the device named outlet as backyard in Google home and you can see the issue below…

Hey google, sync devices…
After you go into:

Open your Home Assistant instance and show your voice assistants.
And set up your entities.

Yeah that is very weird that it hears you correctly, but works sometimes and not others. When I originally set mine up I remember there was one name that confused it, I think because it was too generic (can’t remember how it behaved though). This might be the case with “outlet”, as it might be treated a bit like a redundant word - eg. “turn the fan off” vs “turn the fan outlet off”. Maybe then it’s interpreting it as “turn the backyard on” and you have no device with that name (not sure if “backyard” is part of the name or a room in your case). So it might be worthwhile renaming it to see if that helps (eg. “turn the backyard garden on”).

I’m using manual integration per the guide. There is no way to sign into Google assistant integration it’s all handled by the YAML as defined in the guide. I’ve verified the sync my devices phrase to no avail, it will sync and show the status of my devices and I can even click and successfully toggle the state of the switch from the assistant response ui on screen.

Hmm. I’ll try out renaming it. I have expose_by_default enabled and it doesn’t seem to be a visibility issue as it works ok through Home app.

Can you please provide me your entity config if you have one. I kept it simple, didn’t directly assign a room in the configuration.yaml I doubt that’s important as I assigned them to rooms in home app but just want to check against a known working config.

It it doesn’t find an entity or device, it then looks toward area for a match.
Generally if you push the sync button ot tell the google speaker to sync devices, it cleans stuff up pretty well. There are exceptions for some words.

I have had keywords that were a bit too clever and the google thought I was asking for a search. Start playing a song that kinda matched or something.

1 Like

You’re not too far off sometimes saying turn on outlet turns on some weird podcast. It’s not an issue of the entity not showing or syncing, that seems to work pretty consistently but the voice command isn’t. Thanks for the advice, give me like 10 min. Anyone have reccomendations for what I should name the entities in HA, like I would assume I should name it just lamp in HA then assign it to a room in Home app and then use phrases like turn on my lamp in the living room…

I have a fan named George, a curtain named Frank and another named Dick. I like to be creative. Seriously…
Set George to 33%…
Set Dick to 100%.
It’s awesome…

Sounds like it, :joy: For now I’ll give it a more creative name. Can you give me any advice on how to name it? Should I set the name in HA or is there some entity attribute I should set to map the name in home app.

Just add an alias, Google or all the voice assistants will use it and you won’t mess with any running automations/dashboards.

Be sure to sync again afterwards.

Alias in which menu? HA gui, HA configuration.yaml google-assistant section, or the name of the device in the Google home app itself.

Sorry I’m asking so many questions, but sometimes it’s easier just to refer to a known working setup vs playing the guessing game as to what Google’s assistant wants to hear lol. For now I gave it a random name just in the home app and it seems to be consistently working. Will update if that breaks like it did last time.

Find the entity, go to the gear in the UI and add an alias

Does that propagate through to assistant? Guess I’ll play with it and find out.

Thanks a lot guys, am glad for once it’s something simple.

Guess I deserve that for calling a smart plug “outlet” :roll_eyes:

If you sync again, it does.

If one of these responses solves your problem, please consider clicking solution on the one that was most helpful.