Google assistant - missing redirect_uri field [solved]

Hi all,

I got a problem with component google assistant. I tried 10 times to follow the guide but with no luck. I created google action and generated on my rpi3 client_id and access_token but I cannot see on google home app the app test.

my hass is over SSL on a port 8123 , I can enter from outside and i have a valid letencrypt cert.
every time I try to reach https://mydomain:8123/api/google_assistant/auth?api_password=password

I got THIS:
{“message”: “missing redirect_uri field”}

I guess something is wrong…
project name is correct , I double checked.

project_id: myProj
client_id: long string generated
access_token: long string generated
agent_user_id: mymail
expose_by_default: true
api_key: generated KEY

I would be very thankful if anyone could help me… yesterday I passed all the night trying getting it up and running with no luck :frowning:

all the best


Maybe the URL on the Google side?

mmh but on google side i set up only my domain…which URL do u talking about?

You need more than just your domain…

yep i know… i followed this video

I have never seen that video but I suggest you look up the component and follow the steps there. It’s easy to miss something in a video and sometimes things are assumed or are missing.

I followed the link , same problem… is there a way to debug the component , maybe form google side if there is connection from my side ?

solved. everything was ok but I was logged in the google home app with a different user ( linked to my default one).
It seems that different users can’t share the test app project eachother.

BTW everything is ok.
I hope that can help someone.