Google assistant only working in english


#1

Today i configured the google assistant component and it kind of works.
My native language is german and when i have my phone set to german i can only use the google home app to controll home assistant.
Google Assistant always tells me that the device/lamp has not been configured.

When i change my phones language to english, google assistant magically starts to be able to turn on my light etc.

Does anyone have any idea what this might be? Do i possibly hit a bug?
What are the chances of google home mini working besides the assistant app not working in german?

I am looking to evaluate google home to voice controll my entire home, but i am not willing to spend so much money on something i could only use in english


#2

Did you create your own Action on the Google Console by following the Google Assistant Component Tutorial?

If so, did you configure your actions also for German or English only? You could try to add German there if you did not before. After changing this you have to create a new draft version by clicking “Test” in the simulation tab. You might need to re-setup your test app in the Google Home App again to test the change…


#3

Hi Florian,

you are right, i did not set up the german language (I was not even aware i can have different languages)
But after i did it i do get the same results…

Any more suggestions on what to do?


#4

First make sure GA still works when speaking English. I for myself have to relink HA to GA when I change the Google Action. If you no longer can control your devices in English relink it again before trying anything else.

Afterward you could check the Assistant Language Configuration in the Google Home App. Does it include German and is it the foremost/top selection of all selected languages?

If you can still control your devices in English you could try some general command without using your device’s name, e.g. “Turn on kitchen light” (in German of course). Does GA act on those commands?

If none of the above solves it you should check your device names. GA is sometimes picky to understand you based on the device names. Are they “German sounding”? We had a similar case like yours here in the forum already (I think it was an Italian user) and everything resolved themselves after changing room and devices names. I can’t find the post though…


#5

Thank you for all your patience @Florian
I managed to get it working by deleting english from my project all together.

I have no clue why my phone wanted to use english for google assistant at all, but now it is solved. Thank you very much