Google Assistant only works on one google nest device?

I’m a noob and go HA working with google assistant using the guide (Google Assistant - Home Assistant). I am not using the cloud service. At first, it seemed to work fine. I tell it to fire a scene such as “ok google, kitchen mode on” and it fires the scene. This being when i’m talking to the google nest in my kitchen (the one with a screen).

When I walk to the family room and give the same exact command to a google home speaker sitting there, it does not fire and says “one or more devices are not available. you might want to try setting them up again.”

Anyone know why this might be?

Curiously it says the same thing if my wife tries to give a command on the google nest in the kitchen. i.e. it only fires in the kitchen and only when I give the command.


Do you have voice recognition setup? That may explain why your wife’s voice won’t trigger it.

Yes I believe so. I even did the re-teach thing in the google home app where it makes you say a series of phrases on the google home in my family room and then rebooted it. That didn’t fix it. Also the wife’s account is shared and also configured.

Are they all the Nest Hubs the same generation (1stGen vs 2ndGen)? Just trying to get a feel for your setup.

Did you sync the devices as well?

I think that you’re on to something…

I have a bunch of these devices of various kinds. I have a nest hub max, a nest hub, several home minis and several original google homes. I went around testing them and basically everything without a screen (google home, home mini) doesn’t work and everything with a screen does (nest hub, nest hub max).

  1. I tried telling the device to sync devinces
  2. I tried firing off a scene via “ok google, activate cooking mode” or “ok google, cooking mode on” (both work on devices where firing off a scene works).
  3. I tried turning on all lights in my kitchen area via “ok google, turn on kitchen lights”.

If I give the command to sync devices (#1 above), it only works on the nest hub and nest hub max. When I try the command on a google home or home mini I get back “four devices can only be sync’d by the user who added them in the google home app”.

It I give the command to run a scene (#2 above), it works on the nest hub and nest hub max, but not the google home and home minis. When it fails I get back the prior mentioned statement.

Oddly, if I give the command to turn on all lights in the kitchen (#3 above), it works everywhere.

So it seems as though the home and home mini’s aren’t able to figure out that I am indeed the user that added the devices in the google home app. I am of course. And as I mentioned earlier, I did retrain voice detection in the google home app and then rebooted one of the home mini’s but the problem persists.

So I am not yet sure what is going on here. Nor why turning on all the lights in the kitchen works. I would’ve thought that wouldn’t work either on the home and mini. There is some kind of permissions or voice detection issue going on here.

Thoughts anyone?

Update. So I went into the google home app on my iphone and started looking at the devices that weren’t working again. Initially, they looked configured and the voice recognition and sharing was linked to my and my wife’s accounts. Voice match on, personalized results on. I didn’t see anything wrong.

So I decided to remove the device and factory reset it and add it back to google home. After that, it worked! At least for me. I can now sync devices and I can bark scene instructions and they’ll run.

Oddly, it still doesn’t work for my wife on any devices when trying to trigger a scene. She can trigger individual devices or all lights in an area but not a scene still. I suspect that I need to get on her phone and mess with the google home app somehow as well.