Google Assistant SDK, Error 403: access_denied

Good morning to the whole community, I have just registered and I am happy to be here, too bad I have to start immediately with a problem.
Today I tried to install the “Google Assistant SDK” add-on to expand the potential of my Home Assistant.
I followed the instructions and created a new project on the Google Action Console, downloaded the credentials and copied to the shared folder “hassio / share”, compiled the configuration file with the credentials file name, the Project ID and the Model ID.
The component starts without errors and the message “ENGINE Bus STARTED” appears, at which point open the Web UI to activate the authentication process, select my account and then the error message appears:

Authorization error
Error 403: access_denied
The developer has not granted you access to this app. It is currently being tested and has not been verified by Google. If you think you need to have access, please contact the developer ([email protected]).
Further information
Request details
access_type = offline
response_type = code
redirect_uri = urn: ietf: wg: oauth: 2.0: oob
state = NQIufathALRGB2JpETA3enrQwI6fCn
prompt = consent
client_id =
scope =

Where am I doing wrong? I canceled and redone a new project from scratch with the same result.
Port 9324 on the modem / router is open and working and Home Assistant is externally accessible via the Duck Dns add-on.
My installation is on Raspberry PI 4B with 4GB of RAM on docker supervisor:
Core version-2021.3.4
Supervisor version-2021.03.6
Docker version 20.10.5
Raspbian GNU / Linux 10 operating system (buster), January 2021 release.

No, I had problems integrating Google Home in Home Assistant, with that I see the entities I created on Home Assistant on the Google Home APP.

I hope someone from you can help me!
See you soon.

I answer myself:
in the steps described in the documentation, creating a test user was not mentioned, I assumed that since I created the project I could access through Home Assistant using my account, I had to go to the Google developer console and from the menu "OAuth consent screen "create a test user.
It is now registered regularly.


You need to go to the OAuth settings on the left side in your developers console. Then publish your app so that it goes from “test” to “production”.

I tried looking for that but I couldnt find where the change that. If you could help that would be great.

This worked for me:
Within the project (go to the Google developer console) and from the menu “OAuth consent screen” in “APIs & Services” I created my Google user as a test user. This allows this user (you) to access the project.

You can also set the project (same OAuth consent screen) as public, but that option opens up the project for all Google users (but it also works) :slight_smile: