Google assistant setup?


#22

Cool. Thanks. All working.

By they way; Can it also support thermostats and reading out sensor values?


#23

Not currently, right now it’s only light/switch support. There’s a PR in for climate support though.


#24

I just left it blank…


#25

did you have a connection error issue?


#26

I’m trying to set this up too but I’m always getting a 404 error when I"m trying to add the project in the Google Home app.
So https://HA_INSTALLATION/api/google_assistant/auth is throwing these errors.
Anybody have an idea on how to fix this?


#27

Is it the couldn’t update check your connection error?


#28

Gershy,
If this was a question to me I’ll answer it :-).
The error I get is a literal 404 error when trying to add it in the Google Home app.
It tries to go to my HA instance /api/google_assistant/auth but that returns a 404 error “not found”.


#29

Oh right ok… I’m having a error which says couldn’t update, please check your connection…


#30

For some reason it suddenly started working! No idea what the problem was to be honest…
Now I’m just looking into how to have it read me values of a sensor I have in here with MQTT


#31

thats weird… mine still isnt working…


#32

I had the same error, but then realised that I had updated the config.yaml file but not reloaded the configuration. Google assistant will try and verify the key in your YAML file and if you config isn’t the running config, it’ll give the 404 error.

@Gershy13 did you try running the test draft? I noticed that any changes you make on the Google Assistant app, don’t really take until you test/simulate it…

I ran into a few issues, and would like to point out that the ‘project_id’ in the yaml file must match the project name when you run the gactions update.


#33

I did click test draft yes, and also my yaml file is up to date and I did restart it… But it’s still not working…


#34

Ah, sorry man can’t think of anything else… Did you select the appropriate country in the dev console?

Before mine started working, I got the same error as your, but it worked when I added the app in Google Assistant the second time…


#35

I am getting the following error from the home assistant logs

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[Info] Setup audio device
[Error] You need initialize GoogleAssistant with a client secret json!

I am also getting a 405 Method Not Allowed when I try to access the the app from the home assistant app on phone

Any ideas?


#36

Well I’m from the UK… so first I selected UK, but then the 2nd time I tried I selected us… Both didn’t work


#37

Where is the google_assistant.json file and what should be in it?


#38

https://home-assistant.io/components/google_assistant/


#40

Hello,

I have the same error “You need initialize GoogleAssistant with a client secret json!”…
How did you fix it ?

Thanks,

S.


#41

@Selling - I just set up the Google Assistant Webserver add-on and ran into that error. I was putting google_assistant.json in my config folder - I missed that you’re supposed to add it to “share”, a sister-folder of config.


#43

Hi,

I am getting the same error. I have google_assistant.json in my share folder… any ideas?