Home Assistant Community

Google assistant setup?

#1

Can someone help me?

Im trying to setup google assistant, but im stuck on step 1 believe it or not…

Install the gactions CLI (you’ll use this later) - you can download this anywhere, just remember where you put it for later (and don’t forget to run chmod +x gactions)

Where do i install gactions CLI? On my windows pc or the pi? If on the pi, how do i install it? And where/what/how do i run chmod +x gactions?

Create a new file named project.json (in the same directory you downloaded gactions to) and replace the [YOUR HOME ASSISTANT URL] below with the URL you use to access Home Assistant. Note: This must be an HTTPS URL to work.

And here, does this mean i need to have a duckdns url setup? with encryption?

Please help

Thanks
Gershy13

0 Likes

#2

It doesn’t matter where. You download it to your PC and run it there, or download to your Pi. To “install” it on the Pi run the chmod command.

Yes - externally accessible with a hostname (doesn’t have to be DuckDNS, any dynamic DNS provider will do) and an SSL certificate.

0 Likes

#3

thanks, so if i run it on my pc i dont/cant do chmod anything?

and how would i make it ssl? i have duckdns setup, but its not https.

0 Likes

#5

and can client ID and access token be anything i want?

0 Likes

#6

in the duckdns lets encypt addon for hassio, im getting this issue… any ideas?

Details:
{
“type”: “urn:acme:error:malformed”,
“detail”: “Error creating new authz :: DNS name does not have enough labels”,
“status”: 400
}

0 Likes

#7

Yes, but they’re effectively passwords so make them long and random:

cat /dev/urandom|fold -w 120|head -n 1|base64 -w 0|tr -dc '0-9A-Za-z'|cut -c -80

I don’t run HassIO so I can’t help. It sounds though like you used myhost and not myhost.duckdns.org.

0 Likes

#8

what is the full chmod command to install on rpi

0 Likes

#9

The instructions are on the page you download gactions from.

0 Likes

#10

When I run it it says factions not found

0 Likes

#11

Do I use chmod +x gactions

0 Likes

#12

Please read step 2. It tells you to call it as ./gactions

Yes (that’s what it says to do after all :wink: )

0 Likes

#13

Thanks I’ll change it and give it a shot.

0 Likes

#14

please help
27

0 Likes

#15

Use “sudo” before all commands

sudo chmod +x ./gactions

Also I got no such file also. It means its looking g in wrong folder for file.
Just use full file path. So if file is in /home/user/folder

Sudo chmod.+x /home/user/folder/gactions

0 Likes

#16

Am I meant to have downloaded the x86 version and transfer to rpi then run command in folder location

0 Likes

#17

Thanks… I changed it, and there aren’t any errors… But I’m trying to access my site with Https://mydomain.duckdns.org:8123, but it’s not working… If I use http it works fine… Any ideas?

0 Likes

#18

I’m having another issue now… Everything is configured and working fine, but when I try and add it in the Google app, it shows up, and seems to work, but then it says loading and then claims a connection error. Ideas?

1 Like

Google Assistant: How to control HA form my phone's Google Assistant
#19

Setting it up right now but what do you enter as a link to a privacy policy? Can anyone point me in the right direction how to do this easily?

0 Likes

#20

You download the version for the system you’re going to run it on. You can download and run it on your Windows PC if you’d rather.

0 Likes

#21

I just made up a link on the domain being used (/privacy.html).

0 Likes